Printer through Terminal Server 2008 Via VPN

Posted on 2010-08-12
Last Modified: 2013-11-21
HI Team,
Can some one please assit urgently on the following problem
- We have a PC running XP which connects via VPN successfully
- That PC then RDP into a Win2k8 Server using local IP as PC is virtually on the same network as the terminal Server, after making VPN connection
- That PC has a local printer installed ( via TCP / IP Port )
- Local printing works FINE
- Printer is successfuly ampped in the Terminal Session
- When we send Print jobs they go NO WHERE and  do not print
0- NO Error message is displayed


- shared the printer on local PC
- tried installing the Printer in the Terminal Server as shared prinetr
STILL does not print


tried connecting to the terminal Server diectly with itps Public IP with out VPN, but still job can not be printed.

ANy Help will be hihgly appriciated
Question by:aspiremsp
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 2
  • +1

Expert Comment

ID: 33426326
Do you have the windows 2K8 printer drivers installed  on the 2k8 server?

Author Comment

ID: 33426342
Could you please Elaborate ? How would be able to install that, printer can be seen in the terminal session.
Thanks in Advance

Assisted Solution

girk earned 100 total points
ID: 33426361
You can install the printer driver on the 2K8 sever and point it to LPT1 or LPT2 and never use it.  Then the driver will be on the server for you to use with RDP.
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.


Author Comment

ID: 33426388
Ok i will give it a try and willupdate you soon

Author Comment

ID: 33426608
HI Qirk,
We installed 2k8 Driver for that printer.
replicated the issue, Print wtill does not work.
Thanks in Advnace,

Expert Comment

ID: 33426703
Well its not the most Ideal way to do it but you could do a network share on your printer. Then add it to your 2K8 Server.

Expert Comment

ID: 33426725
Are there any errors in the system log in the windows logs folder in event viewer in administrative tools that might shed some light on what is going on.
LVL 31

Accepted Solution

Cláudio Rodrigues earned 200 total points
ID: 33430199
No need for any drivers on the TS assuming you use Easy Print (what you should do).
If not using Easy Print then yes, the exact same driver must be on the TS but if the printer was shown under the session it means it was autocreated.
Check for permissions in the SPOOL directory on the TS.
Does this issue happen if you logon using admin credentials? I mean from that same PC instead of opening an RDP session as a regular user, what happens if you go as a user with admin rights? I do not mean give admin rights to your users; this is for troubleshooting only.

Cláudio Rodrigues
Microsoft MVP - Remote Desktop Services
Citrix CTP

Author Comment

ID: 33450591

 I Will Check  it with Admin user and will also check the spool directory.

What did you mean by using Easy Print ?  Please do note that use is logging on to TS using VPN.

could that be an issue?
 in the LAN users log on to TS and they can send the prints easily. Issue only happend when they log on to TS via WAN or using VPN externally ?

Thanks in advance.
LVL 17

Assisted Solution

Spike99 earned 200 total points
ID: 33465908
I would check your firewall settings.  Printers use port 9100 (check the printer properties, click on the Ports tab, click on Confgiure Port button).  If the printer is on a multi-port external print server (like the 3 port HP JetDirect), then the ports used are:
Printer1:  9100
Printer2;  9101
Printer3:  9102

If that port is blocked on your firewall, you would see this behavior (printers will redirect but print jobs go nowhere).

You can telnet to HP printers, so try this command to test that port:
    telnet xx.xx.xx.xx 9100, where xx.xx.xx.xx is the IP of the printer

If it fails from the terminal server but you can telnet over that port from the local LAN, I think your firewall must be blocking port 9100.

I don't think Easy Print will resolve the issue, but it can eliminate the need to install OEM drivers.

Users must be using RDP 6.1 to use Easy Print.  RDP 6.1 is included with WinXp SP3 (or it's available as a separate download for SP2), Vista SP 1 and Windows 7 operating system.  XP & Vista users have to have .Net 3.0 SP1 or better installed to use the Easy Print driver on the TS.  Windows 7 users need no additional software installed.

MS Technet article on Easy Print:

I hope this helps,

LVL 31

Expert Comment

by:Cláudio Rodrigues
ID: 33466033
I assume all your printing is handled by RDP printing redirection. If that is the case, again, Easy Print will solve ALL your issues, for internal or external users. And eliminate the need for installing any drivers on the TS what is really a worst practice and usually a terrible idea.

Cláudio Rodrigues
Microsoft MVP - Remote Desktop Services
Citrix CTP

Author Comment

ID: 33497339
Thanks for constant help so far to "tsmvp" and "Spike99".

I will try easy print and check firewall as well. but one strange thing found. That user was able to printer email attachments from with in Terminal session but he/she was unable to print the outlook email as such.

in the mean time i will install Easy print and let yuo know.

Author Closing Comment

ID: 34081535

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Some time ago I faced the need to use a uniform folder structure that spanned across numerous sites of an enterprise to be used as a common repository for the Software packages of the Configuration Manager 2007 infrastructure. Because the procedu…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question