Solved

BES  Express 5.0.2 MAPI Error during Install

Posted on 2010-08-12
16
3,876 Views
Last Modified: 2012-05-10
I am trying to install BES Express 5.0.2 on a Windows Server 2008 R2, we have Exchange 2007, and during the installation its ginving me an unecpected error, suring the Mappi Settings portion of the installation.
0
Comment
Question by:clebovits
  • 5
  • 5
  • 3
  • +3
16 Comments
 
LVL 1

Expert Comment

by:PRichardYabut
ID: 33426886
Did you install it by first and foremost creating the BESAdmin account?
That error is usually caused by the BESAdmin account not having the correct permissions.  The "Administrator" account won't cut it.
You can start over uninstall and clean the installation or since you're already into the installation,  you can manually modify the "rights" of the administrator account and provide it the "needed" rights in Exchange System Manager.
Whatever you do, make sure the BESadmin account also have "administrator" rights on the Local Machine - not the domain admin or such but the "local" machine itself.  Then give the BESAdmin Send as/receive as permissions.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33426989
I'll go with PRichardYabut > @ BESadmin account.
Try logging in through the besadmin account >
BesAdmin should be part of domain Administrators.
0
 

Author Comment

by:clebovits
ID: 33429565
BESAdmin is set up as administrator, and does have sendas and receiveas rights.
 

ERROR.tif
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33429627
Can you upload the logs from here
c:\Program Files\Research In Motion\BlackBerryEnterprise Server\Logs

if it's not there, the correct log path can be found from the following registry key.

start > run > regedit
navigate to this

HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\BlackBerry Enterprise Server\Logging Info

thanks
0
 

Author Comment

by:clebovits
ID: 33429728
0
 
LVL 1

Expert Comment

by:PRichardYabut
ID: 33431304

Is BES on the same BOX as Exchange?
Did you give the BESAdmin account Admnistrator rights on the Local Machine it is installed in?
The Log also showed connection failure to the SQL database for BES
0
 

Author Comment

by:clebovits
ID: 33431310
Yes on Both
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33431407
Is the SQL Server running with BESAdmin login details.
Can you let me know how are the services running

SQL Server under local system account or besadmin ?
You can change it to local system account and then try the install

start > run > services.msc
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 1

Expert Comment

by:PRichardYabut
ID: 33431449
what sunnysaid.
Check that all the BES services are all running under the BESadmin account and not local system...
0
 

Author Comment

by:clebovits
ID: 33431555
I am attaching the SQL Services its running
SQL-Service.png
0
 
LVL 28

Accepted Solution

by:
sunnyc7 earned 125 total points
ID: 33432280
i was trying to download that image on my blackberry and my phone errored out.

Can you change the logon as to DOMAIN\BesAdmin account
Verify that is the case.

Double click the service click on logon tab.

if that doesnt work.
Set it to Local System Account and restart the service.
then retry the install.

thanks
0
 

Author Comment

by:clebovits
ID: 33456961
I created a new VM, and installed on that Machine, and it works now, thanks for your help anyway.
0
 

Expert Comment

by:AxisFirst
ID: 33466469
We had the same issue on Windows 2008 R2 with exchange installed locally. It seemed to be that BES was using the IPV6 address to lookup the local dns name when doing the MAPI Call

If this is the case you can test by pinging the dns name of the excahnge server and it will reply with an IPV6 address. this is due to it using the IPV6 loopback address in the host file.

To Get around this we put two entries in the host file (C:\windows\systems32\drivers\etc\hosts) along the following format
127.0.0.1                            localhost
servername                        IP Address
servername.domain.local   IP Address
::1                                       localhost#
This worked around our problem, not sure if its the same as yours WAS but thought i would share anyway
0
 

Expert Comment

by:PurityIT
ID: 34100918
Hi,

We too are having a similar issue but we are on Windows 2008.  I added in the entry to the hosts file but when I pinged the server name it returned back an IPv6 address.  Should this still happen ?
0
 

Expert Comment

by:nicolasgreening
ID: 36182749
Hi All I am having the same issues.

I am installing BES Express 5.0.3 on a 2008 R2 server running exchange 2007 and when I get to the MAPI setting page I get the same error. see the log file the text file attached Setup20110713173336.log

Not all the BB services are running I have tried to strat these with both the Besadmin and local system accounts Services
Any help would be great
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 36183616
From your log file.

User elects to allow the installation continue though an error occured on validating the SRP info
>> Validate your SRP from here
https://www.blackberry.com/SRPAddressLookup/

Troubleshooting steps here:
http://www.besadmin.info/KB13983/Invalid-SRP-KEY-or-ID-error-received-when-validating-the-SRP-key-and-ID

>> restart all Blackberry services as automatic and under Domain\BesAdmin account.

i'd suggest please post a new question, so that it can get the attention it deserves.

thanks
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Resolve DNS query failed errors for Exchange
Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
This video discusses moving either the default database or any database to a new volume.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now