?
Solved

how to copy large files from/to smbfs file system

Posted on 2010-08-12
7
Medium Priority
?
797 Views
Last Modified: 2013-12-15
I have two Windows drives smb mounted on my Linux slackware (kernel version 2.6.21.5) computer. I want to copy a file from one drive to the other. There is plenty of actual space on the target drive. The file is: 85,484,137,984 KB, i.e. +83GB.

On the linux machine I used a simple: cp src dest. It copied about 2GB then halted with the message 4616 File size limit exceeded

I went to Windows and used Windows Explorer to copy the source file and paste it to the destination. It copied just fine.

why can't Linux to do the copy? Is there a way to fix this? This is rather important because the Linux host is supposed to be responsible for copying backup archives to offline storage. I would be shocked if Windows was capable of something Linux was not.
0
Comment
Question by:jmarkfoley
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 84

Accepted Solution

by:
Dave Baldwin earned 668 total points
ID: 33427077
Apparently you need to 'enable large file system' support.  Found a lot of Googles about the 2GB limit.

I found this but I'm not sure what it means: http://www.linuxquestions.org/questions/linux-networking-3/samba-file-size-limit-372039/

mount -t smbfs -o lfs //server/share /localdir

the 'lfs' tag tells the server to enable large file support. obviously, replace //server/share and /localdir with the appropriate paths.
0
 
LVL 16

Assisted Solution

by:santoshmotwani
santoshmotwani earned 664 total points
ID: 33427220
0
 
LVL 7

Assisted Solution

by:expert1010
expert1010 earned 668 total points
ID: 33427549
There were problems with older samba. smbfs had a limit of 2GB a few years back. With kernel version 2.6.21.5 it points to at least 3 years old kernel. If  samba is that old, or older it might be an issue. There could also be the "large file size" problem. Try mounting with -o lfs, or you might try mounting it with -t cifs instead.
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 1

Author Comment

by:jmarkfoley
ID: 33431989
We're getting there, but still troubles

the mount -t cifs, as shown in santoshmotw...'s link or any other way I try it does not appear to be supported by my mount command. I get mount's mini-help in response as if I made some kind of syntax error. My mount version appears to be 2.2r.

I also tried mount.cifs directly:

mount.cifs //OHPRSSTORAGE/Backups /OHPRSstorage -o user=usr%pw

I also tried the domain option. In all cases I get:

mount error: could not find target server. TCP name OHPRSSTORAGE/Backups not found
No ip address specified and hostname not found

I'm not sure what to do with that information as the resource //OHPRSSTORAGE/Backups is legitimate and I use it successfully with smbmount.

I did try the smbmount command with the lfs option. That seemed to work better, but after about 10 minutes of copying I get the error:

cp: reading `/OHPRSstorage/Acronis/MAIL/Archive(1)_2010_08_10_02_00_16_490D.TIB': Input/output error

I've tried a couple of times. It dies after copying between 4GB and 5GB, or as I said, about 10 minutes.

I've set debug level to 10 in smbd, but I see no additional info in log.smdb.

Thoughts? I'm really trying to get this accomplished today before the backup runs just after midnight.
0
 
LVL 1

Author Comment

by:jmarkfoley
ID: 33433940
Tried it again, this time it took 27 minutes to generate the Input/output error, but only copied 1.4GB Any ideas at all would be appreciated. I always thought samba was more robust than this.
0
 
LVL 7

Expert Comment

by:expert1010
ID: 33439726
It might have to do with this. https://bugs.launchpad.net/ubuntu/+source/samba/+bug/46514. If it is the only thing to do is to upgrade. Ok, it's not Ubuntu but it's still old samba, right?
0
 
LVL 1

Author Closing Comment

by:jmarkfoley
ID: 33469553
Points all around. No one had the exact answer, but the responses put me on the right path of discovery. Thanks.
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Suggested Courses
Course of the Month8 days, 22 hours left to enroll

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question