Sonicwal SSL VPN connected, but can't access remote LAN

Hi guys.
i'm done... it's been 4 hours of research and testing and i'm just done being a typical man, and i'll ask for help :).

We're using Sonicwall TZ100 enhanced OS 5.6.
Downloaded the SSL VPN NetExtender and set it up like shown on
this video

i am able to connect, and am getting an IP address from the TZ100.

Even though i have an IP, i can't ping any IP address on the VPN LAN side.
I noticed that when i do IPCONFIG, the VPN tunnel doesn't have a gateway. not sure if that's normal or not...

the office LAN subnet (where the sonicwall is located) is 10.0.125.x
the remote home subnet (where the remote computer is located is 192.168.2.130
no conflicts there...

i tried creating some rules on the NAT and firewalls, and open / allows any to any... no dice...
i disabled the firewall (windows firewall) on remote PC- still no help...

BUT- when i enabled the "Tunnel All Mode" (see attached image) option on the SSLVPN menu on the appliance, i was able to ping the remote network devices, but then i couldn't connect to the internet from the home PC...

so i'm pretty sure it's a firewall or NAT or routing rule that i can't  think of.

what am i doing wrong ?!
thanks in advance !


sonic.JPG
beitsAsked:
Who is Participating?
 
SteveIT ManagerCommented:
Have you checked your DNS settings on the server and the sonicwall as well as any rules on firewalls to permit traffic on sonicwall ip range to your internal network.

We moved our sonicwall on a DMZ which makes config easier
0
 
sosinc3Commented:
I am pretty savy with SonicWall VPNs but really to help you better I would need to see more of your setup. If you are able to attach screen shots from your vpn and network screens as well local users screens that would be helpful. If you want to protect things a little, you can wipe out the IP address/keys, etc. from your screens and replace them with some phony ones before you take the screen shots (just don't save them and you won't hurt your setup that way).
0
 
digitapCommented:
It's not NAT.  When you enable the SSL-VPN on the TZ series, then you fall undert the SSL-VPN zone.  You don't have a gateway because you only want to route traffic that the sonicwall owns.  You want to route anything else out of the local gateway from where you have the SSL-VPN configured.  Tunnel All means just that.  You tunnel all traffic through the ssl-vpn connection...period.  It sounds then, like you haven't a route or something like that configured improperly.
0
 
beitsAuthor Commented:
hi guys.
thanks so much for the replies.
your answers made me dig deeper, and i found that it was a firewall rule that was not created correctly on the sonicwall.
i recreated the rule to allow SSL VPN all traffic to LAN, and i was able to ping the LAN PC again.
after disabling the LAN PC firewall, i was able to access the shares... woo hoo !

thanks again !

Beits
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.