Exchange 2010 Certificate Problem

I have purchased a certificate from GlobalSign, which works for owa internal link:
https://exchange1/owa but when the Outlook 2007 Client connects to my exchange 2010 server I get the certificate error that the name on the certificate does not match the name on the site.

I saw this post: http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26166895.html

which is the same issue, bit I don't understand what I need to do to get it to work.

Can someone give me a hand please???
LVL 2
andrewjones1987Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
woolnoirConnect With a Mentor Commented:
you need to make sure your clients are connecting to the same name i.e https://exchange1.FULLDOMAINNAME.com/owa. The certificate can have an entry for a 'simple name' but otherwise the clients need to connect to the full external name as external clients would.
0
 
Tomas ValentaIT ManagerCommented:
The certificate is created for FQDN of host. When this certificate is used in web server site the client connect to this site and make some security checks on certificate - validity, trust and if the host you are connected is equal to the host for what was certificate issued.
If you use this server from Internet and from internal site under different hostnames you must make changes in your environment to be able not receive error messages. what name is on your certificate, what name is filled in Outlook in Exchange profile, what is in IIS config ?
0
 
andrewjones1987Author Commented:
Outlook Client: exchange1.ad.domain.org.uk
IIS: https://exchange1/owa   or   https://exchange1.ad.domain.org.uk

Certificate:
Contains - autodiscovery.domain.org.uk
                 mail.domain.org.uk
                 webmail.domain.org.uk
                 exchange1
                 localhost

I Understand about the certificate not containing the exchange1.ad.domain.org.uk, but how do I configure exchange clients (Outlook 2007) to use just exchange1 or even mail.domain.org.uk??? same as external???
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Marc DekeyserSr Premier Field EngineerCommented:
I'll go with woolnoir here, you need to add the external domain name on the certificate as f.e. "mail.contoso.com"
0
 
woolnoirCommented:
go into the account settings in outlook 2010 and for the server address for the account add the full domain name for the server as you registered in the certificate... i.e mail.domain.org.uk.
0
 
woolnoirCommented:
the distinction would be ( using my username )

I'd registered mail.woolnoir.org.uk and had a OWA server. My external clients would use https://mail.woolnoir.org.uk and would work fine. My internal clients would use only MAIL in their outlook server settings and it would fail... as MAIL isnt the FQDN in the SSL certificate... it has to be mail.woolnoir.org.uk for the server setting...
0
 
woolnoirCommented:
Try just changing your outlook from exchange.ad.domain.org.uk to exchange.domain.org.uk.. thats a good first step.
0
 
andrewjones1987Author Commented:
no, the only thing in outlook that will work is when I type exchange1 and then it adds exchange1.ad.domainname.org.uk (ad.domainname.org.uk is my FQDN)
0
 
woolnoirCommented:
But you can go into the account settings preferences and changes that manually after you have configured the account ? I know it suggests the details but it shouldn't auto add them ? thats auto discovery happening but it should be manually tweak able ?
0
 
andrewjones1987Author Commented:
No.....I select Manually configure and when I enter the Server name and my Username, it adds the last bit during the check name process as seen when I go back into the settings.
0
 
ValutusCommented:
This article explains how to set the internal URL in Exchange 2007 (it also applies to Exchange 2010) http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/configuring-exchange-server-2007-web-services-urls.html

Setting the Internal URL to match your external URL it should resolve the issue.


0
 
DeDeckkerAndyCommented:
Open exchange mgmt console
server configuration
Client Access
select your server
-click properties, last tab Outlok Anywhere - fill in the external host name mail.domain.org.uk
-click ok

On tab Outlook Web App - click owa and click properties
there --> external url mail.domain.org.uk, click ok
on tab Exchange Activesync - click Microsoft-Server-ActiveSync, click properties
there --> external url mail.domain.org.uk, click ok

Point the external dns from mail.domain.org.uk to the right ip address

that should do the trick
0
 
woolnoirCommented:
Any luck on this issue ?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.