Solved

outgoing smtp connector in exchange 2007

Posted on 2010-08-13
16
552 Views
Last Modified: 2012-05-10
hi, when i change the outgoing smtp connector to relay through my service provider instead of my servers dns the mail just goes in a queue. I am using sbs 2008 server with exchange 2007. I change it back and it runs fine. I have done this many times on 2003 servers without any issue. I have tested the connector on outlook in the pop3 settings and it works fine. I am wondering do i have to do anything else in exchange 2007 to enable it other than: going to organization conf, hub transport, send connectors and changing the settings on the network tab on the connect to go through a smart host. I used to be so much simpler on the previous version of exchange!
0
Comment
Question by:fbs-helpdesk
  • 7
  • 5
  • 2
  • +1
16 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33428620
Your ISP probably needs authentication - check with them and find out then set the credentials on the Send Connector> Network Tab> Smart Host Authentication Change Button.
0
 

Author Comment

by:fbs-helpdesk
ID: 33428708
spoke to ISP and no authentication needed, i guess as much when i did not need to put it in when using outlook
0
 
LVL 2

Expert Comment

by:goraek
ID: 33428756
Enter your ISP SMTP mail setting in the smarthost (eg. mail.domain.com).
This will enable you to send emails.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33428757
Have you checked that Authentication is NOT set currently on the connector?
Also, are you using an FQDN or an IP Address for the SmartHost?
0
 
LVL 4

Expert Comment

by:ebooyens
ID: 33428781
Best way to do this in SBS08 is in SBS Console, Network, Connectivity and at the bottom it has Smart Host for Internet E-mail.

Test mail flow through the smart host by using telnet from the server (may need to add it to the server by going to Server Manager, Add Feature).  So at a command prompt do "telnet smarthostaddress 25"

Here's some steps for using telnet to send an e-mail:

telnet mail.domain.ext 25
You should receive a reply like:
Trying ???.???.???.???...
Connected to mail.domain.ext.
Escape character is '^]'.
220 mail.domain.ext ESMTP Sendmail ?version-number?; ?date+time+gmtoffset?

You will then need to delcare where you are sending the email from:
HELO local.domain.name - dont worry too much about your local domain name although you really should use your exact fully qualified domain name as seen by the outside world the mail server has no choice but to take your word for it as of RFC822-RFC1123.
This should give you:
250 mail.domain.ext Hello local.domain.name [loc.al.i.p], pleased to meet you

Now give your email address:
MAIL FROM: mail@domain.ext
Should yeild:
250 2.1.0 mail@domain.ext... Sender ok
If not, contact ISP and tell them it's not accepting e-mails from your domain

Now give the recipients address:
RCPT TO: mail@otherdomain.ext
Should yeild:
250 2.1.0 mail@otherdomain.ext... Recipient ok
If it doesn't speak to ISP - they're not allowing e-mail relaying from your IP

To start composing the message issue the command DATA

If you want a subject for your email type Subject:-type subject here- then press enter twice (these are needed to conform to RFC 882)

You may now proceed to type the body of your message (e.g. hello mail@otherdomain.ext from mail@domain.ext)

To tell the mail server that you have completed the message enter a single "." on a line on it's own.
The mail server should reply with: 250 2.0.0 ???????? Message accepted for delivery

You can close the connection by issuing the QUIT command.
The mailserver should reply with something like:221 2.0.0 mail.domain.ext closing connection
Connection closed by foreign host.
0
 

Author Comment

by:fbs-helpdesk
ID: 33428791
authentication is set to none and i have tried the fully qualified domain and and the ip address
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33428819
Okay - what outbound TCP port(s) are you using on the connector?  25 / 587 or something else?
Is your ISP blocking outbound TCP port 25?
0
 

Author Comment

by:fbs-helpdesk
ID: 33428867
do i have to restart any service after i run this:

Best way to do this in SBS08 is in SBS Console, Network, Connectivity and at the bottom it has Smart Host for Internet E-mail.
0
Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

 
LVL 4

Expert Comment

by:ebooyens
ID: 33428937
No, you shouldn't have to restart any service.  Have you tried the telnet commands?  This will tell you if there is a problem on the ISPs end.
0
 

Author Comment

by:fbs-helpdesk
ID: 33429841
I just installed telnet and all the commands ran through fine
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33429900
Can you please follow the Exchange 2007 section of the following link to make sure you are setting things up properly (which I am sure you are - just want to be sure):
http://www.arrowmail.co.uk/howto/smrthost.aspx
0
 

Author Comment

by:fbs-helpdesk
ID: 33430378
I went through the above link, all looks fine. I only have SP1 for exchange on it now. i will install SP3 over the weekend and see if that makes a difference
0
 
LVL 2

Expert Comment

by:goraek
ID: 33435016
SP3 has nothing to do with it from an operation point of view. It should work regardless what patches you have - if it is SP3 that will fix it, then organizations with SP1 should upgrade to SP3 too, if ya know what I mean.

This is a configuration and routing issue, you should look into it, though it is recommend to upgrade to the latest SP from an update and security perspective.

You will need to double check your settings again, I suggest the following:

- Send connectors
- Receive connectors
- Accepted Domains
- Port forwarding (Port 25)
- NAT (external to internal)

One misconfiguration in any of the above will fail to perform any mail activities.

NOTE: This works for both Exchange 2007 and 2010 on Server 2008.

Cheers,
Goraek
0
 

Accepted Solution

by:
fbs-helpdesk earned 0 total points
ID: 33576568
sorry for the delay all, the service provide had upgraded it's spam engine and block all mail that had a signature, that what was blocking the mail

thanks again for your help
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33577437
No problems - glad you have the issue resolved.
Don't forget to close the question down accepting your last comment as the answer.
0
 

Author Closing Comment

by:fbs-helpdesk
ID: 34328636
Help from all contributors resolved thanks!
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Resolve DNS query failed errors for Exchange
Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now