?
Solved

Can't change file association for Docx from wordpad to to Word 2007

Posted on 2010-08-13
4
Medium Priority
?
842 Views
Last Modified: 2012-09-21
On a Dell Inspiron 630D laptop running XP Pro/Office 2007 Std in a Windows 2003/2008 domain, this laptop always tries to open a file with a docx extension using wordpad. When it does open in wordpad, it displays junk.

I went into folder options and checked what app is registered to the docx file type and it says winword but wordpad always launches when you click the file. I clicked change in Foler Options and selected c:\program files\office12\winword.exe but it does not update the file associations.

If I launch word 2007 then select open and click the file, it opens fine.

Any suggestions?
0
Comment
Question by:Tony Giangreco
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 4

Expert Comment

by:lkraven
ID: 33431119
One solution is this program:

http://www.baxbex.com/openexpert.html

You may need to make sure you have administrative rights on the laptop in order to change file associations.

Also, try shift-right clicking the file and see if the "Open With" option appears.  Make your setting there.
0
 
LVL 4

Expert Comment

by:ebooyens
ID: 33431128
Try doing start, run

c:\program files\office12\winword.exe /regserver

This should re-register Word and the file types.  Be warned though that I have seen this then pop up and ask for the installation disk, so maybe get that first in case you need it
0
 
LVL 30

Accepted Solution

by:
Rich Weissler earned 1000 total points
ID: 33431129
Check in your registry HKEY_CURRENT_USER\Software\Classes\.docx and see if it doesn't have a wordpad assoc there.  (If it does, remove the .docx key in this hive.)

(I believe the association should normally be HKEY_LOCAL_Machine... which is where you are probably changing it with the folder options.)
0
 
LVL 6

Assisted Solution

by:che6ausc
che6ausc earned 1000 total points
ID: 33436241
Delete the following key in the registry: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.docx.  Then right click on the .docx file and browse to  c:\program files\office12\winword.exe and select.

I don't have XP but it should be the similar to Vista/7.

This will clear all file associations for the extension and then re-assign it to winword.exe
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
Ever wonder what it's like to get hit by ransomware? "Tom" gives you all the dirty details first-hand – and conveys the hard lessons his company learned in the aftermath.
The viewer will learn how to use a discrete random variable to simulate the return on an investment over a period of years, create a Monte Carlo simulation using the discrete random variable, and create a graph to represent the possible returns over…
The viewer will learn how to create a normally distributed random variable in Excel, use a normal distribution to simulate the return on an investment over a period of years, Create a Monte Carlo simulation using a normal random variable, and calcul…

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question