Can't recieve mail from outside my domain

I just installed Centos 5.5. I got domain and already installed Postifix, Dovecot and SquirrelMail compination (http://www.linuxmail.info/). Now I can send emails to everyone succesfully and get emails from anyone who is in my domain, but I can't recieve mails from outside my domain (example: my hotmail account).

So, if somebody can help me i'm very pleased.

My "postconf -n" data:
(my real domain replaced with "mydomain.com")
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
home_mailbox = Maildir/
html_directory = no
inet_interfaces = all
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
mydomain = mydomain.com
myhostname = mydomain.com
mynetworks = 127.0.0.0/8
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_path = private/auth
smtpd_sasl_type = dovecot
unknown_local_recipient_reject_code = 550

Open in new window

MircciAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pieter JordaanSenior Systems Administrator - Web hosting and Network Security.Commented:


Do you get anything interresting the the logs?
The /var/log/mail.log or /var/log/syslog.conf file should have some answers.

Please post any errors.
0
scarybotCommented:
Sorry if this is a bit obvious, but just to make sure/// are you absolutely sure the DNS records are showing something sensible for your MX, and does this resolve to the IP of your mailserver?

If so, run a tcpdump and then send an email from hotmail to your mailserver. If you don't see any SMTP traffic within a few minutes, the mail doesn't reach your server and it's a DNS issue.
0
MircciAuthor Commented:
BitFreeze:
No errors in maillog. When I send to mydomain there is line for that but no for hotmail sending.

scarybot:
When i run reverse DNS lookup (http://remote.12dt.com/lookup.php) it returns my domain name correctly. Tcpdumd dont show any smtp lines when i send from hotmail. When sending inside my domain there is lines: ...mydomain.smtp.... So it's DNS problem? Can you help me for that?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

scarybotCommented:
It does look like a DNS problem - the A records are correct, but you need to set an MX record for the domain in order to tell mail relays where to connect to...

Try this command (install dig if it's not already)

dig (yourdomain) MX

if this returns a line with the letters MX and your server name, then all's well. I'm guessing it won't - this means you just need to login to your hosting panel and add an MX record in there. Remember that MX records are canonical names (like mail.mydomain.com.) with a full stop at the end. If you only have one mailserver, the priority doesn't matter, but 10 is a good number to go for.

Hope this helps!
0
scarybotCommented:
By the way, once you've made the change, it can take up to 24 hours to start working I'm afraid.
0
MircciAuthor Commented:

dig result:

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> mydomain.com MX
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 364
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;mydomain.com.            IN      MX

;; ANSWER SECTION:
mydomain.com.     1800    IN      MX      10 mail.nebula.fi.

;; AUTHORITY SECTION:
mydomain.com.     1738    IN      NS      ns2.nebula.fi.
mydomain.com.     1738    IN      NS      ns.nebula.fi.

;; ADDITIONAL SECTION:
ns.nebula.fi.           12698   IN      A       217.30.180.225
ns2.nebula.fi.          12704   IN      A       217.30.182.225

That nebula.fi is my internet-connection provider, is it ok?


0
scarybotCommented:
OK, this means that all email for your domain is being sent to nebula.fi, hence it's never reaching your server - you want to replace this entry with your own mailserver hostname (through your domain name provider's control panel).

Make sure you add an A record for your server's IP first to give it a sensible name (mail.mydomain.com?), and then use this new name as the MX entry, with a priority of 10.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
scarybotCommented:
For example...

Here are the DNS settings (pretend 1.2.3.4 is your server's IP)...

@ MX mail.mydomain.com. 10
@ NS (your ISP's nameservers)
@ A 1.2.3.4
mail.mydomain.com A 1.2.3.4

Hope this makes sense.
0
MircciAuthor Commented:
MX record added now to my domain and everything working fine. Thank you scarybot, exellent job for a bot!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.