Password recovery on Cisco 2921

How can I reset the password on the Cisco 2921 router?  The cisco instructions say remote the compact flash from rear of unit...  there is no compact flash (at least we don't see it) at the rear of this unit....   Helppppppppp!
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Well, what is the rear to you is the front to Cisco and vice-versa... do you have a compact flash card in it at all? If so, take it out.
to clarify, the "pretty" side is technically the rear and the side with all the WIC card slots is the front.
u have to remove the cover ( see the image ) and try the procedure  in the below


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

My apologies... please disregard my comment.
i have face this problem last week and the image will help you really
try it

Noha Mostafa
also folw the steps in the link

If you dont want to remove any flash cards, you can also enter
ROMmon by hitting a break sequence during the boot sequence:
A break sequence is usually (depends on terminal software, OS, etc.)
singe Break key
(or press all the above one after another to make sure )

once in rommon, just follow Cisco steps from step 5.

This was standard procedure for a long time. Not to mention much more
professional than pulling out flash cards and works without a screwdriver too :)
helpdesk_wlkAuthor Commented:
Tried using the BREAK sequence first... to no avail.  Removing the flash worked first time like a charm.  We are back up...  rock n rollin !!!

1,000 Thanks mate!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.