Solved

SQL Program Login problem

Posted on 2010-08-13
10
630 Views
Last Modified: 2012-05-10
We have two instances of SQL 2005 running.  One is 2005 Express (Timeforce) and the other is the main instance (Fusion database).  We had everything working by disabling the firewall for several months but now we are getting attacked from at external IP on the SA account of both instances so we enabled the Windows Server 2003 firewall.  The Timeforce SQL still works for my remote users but the Fusion SQL database won't let my remote users login to the SA account from the application they need to run.  I don't see where there are any specific entries in the firewall for either instance of SQL.  How can I check to see why the remote users can't login to the Fusion instance under the SA account.  The app that accesses the Fusion DB does run fine on the server itself.

Thanks SQL Instance 1 SQL Instance 2
0
Comment
Question by:chasmx1
10 Comments
 
LVL 15

Expert Comment

by:faiga16
ID: 33434502
What error are you getting when they try to access using SA? Can you post the error message? It might be only a matter of SQL Authentication mode. Check if you have both the windows account and SQL authentication enabled.
0
 

Author Comment

by:chasmx1
ID: 33434594
Attached are the error logs
SQL-Error-Message.bmp
0
 

Author Comment

by:chasmx1
ID: 33434607
error code #2
SQL-Error-Message--2.bmp
0
 
LVL 24

Expert Comment

by:DBAduck - Ben Miller
ID: 33435181
Well the Fusion one is using the default port of 1433 and that will be blocked by the firewall where it was not being blocked before.  The other one is using 1474 as a dynamic port and depending on whether you have SQL Browser enabled or not (I am guessing that you do since the others are able to get in to that application), the users will not see problems getting into the 1474 port.

Now, you could add a rule in the firewall for allowing 1433 port through as well as UDP 1434, but then they would be able to attack again as if the firewall was disabled.

So you either need to change the port that SQL runs on to a non-standard port than 1433 and then you could specify that port number when trying to connect.

corsair,1499
0
 

Author Comment

by:chasmx1
ID: 33435498

The hits are really a problem.  Once I disable the firewall I literally get thousands of hits within minutes on both instances of SQL.  Since the TIMEFORCE instance is running on a non-standard port why is it getting hit?  Also do you recommend moving both instances of SQL to different ports?  We also are letting 1433 traffic through our router.  Shall I shut that down?
Thanks
 
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 3

Accepted Solution

by:
piba earned 500 total points
ID: 33438186
if its not strictly necessary for people/services outside your network to access the SQLdatabase directly i would sure recommend blocking it in the router.

besides that i would recommend creating a SQLuser with less permissions, most applications don't really need SA access. starting with datareader datawriter access and execute permissions on all stored procedures would probably be enough, or otherwise maybe dbOwner on the database but certainly not sysadmin rights of the entire SQLserver, unless there are really good reasons for doing so.. that way if a malicious user succeeds to connect they wont be able to gain complete access over the entire server.

and like dbaduck wrote above setting a specific port for the sql instance and using "server,port" to connect might solve the actual problem
0
 

Author Comment

by:chasmx1
ID: 33439309
I can't ping the corsair server but I can Remote Desktop into it from my home via a VPN.  I can ping all the other servers at the office.  What on the Windows Firewall settings would cause this,  With the Firewall turned off pinging is no problem.
0
 
LVL 24

Expert Comment

by:DBAduck - Ben Miller
ID: 33439345
there is protocol called ICMP that is the ping responder and it could be blocked.
0
 

Author Comment

by:chasmx1
ID: 33442138
Do you know where in the ICMP panel I can turn the pinging reply back on?
0
 
LVL 24

Expert Comment

by:DBAduck - Ben Miller
ID: 33442419
When you go into Windows Firewall on Windows 2003 Server you will see an Advanced tab.  On the advanced tab you will see a section on ICMP.  There will be a Settings button that will allow you to tell Windows how to respond to Ping requests.  Check the boxes you want to allow and then save it.  You should then be able to ping it.
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Stored procedure 4 26
Record open by another user 6 41
Set the max value for a column 7 34
Can’t delete a file 14 86
by Mark Wills Attending one of Rob Farley's seminars the other day, I heard the phrase "The Accidental DBA" and fell in love with it. It got me thinking about the plight of the newcomer to SQL Server...  So if you are the accidental DBA, or, simp…
INTRODUCTION: While tying your database objects into builds and your enterprise source control system takes a third-party product (like Visual Studio Database Edition or Red-Gate's SQL Source Control), you can achieve some protection using a sing…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now