[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 962
  • Last Modified:

Sharepoint Internet site keeps asking for password and then doesn;t disconnect

Hello Experts,
I have a sharepoint site which when I open connected to N/W works fine, but when I try to open the internet/extranet site from internet, It asks for password three times and when enetered does not connect to the site. Not sure what got changed as this was working fine few days before. Can someone please suggest possible reasons for this ? May be some settings changed on server which is causing this for extranet site to show message alert again and again even when login and pwd is eneterd. Thanks for your time and help.
0
passion420
Asked:
passion420
  • 3
  • 2
1 Solution
 
jnbkzeCommented:
add the site (internet facing one) to the trusted sites in internet explorer.

by default Internet explorer allows netbios names to be in the intranet zone, thus allowing you to logon using the currently logged on username and password.

when you connect to the FQDN, it thinks the site is on the internet and then the security levels go way up! :)
you can also try adding the internet site's FQDN into the intranet zone (if it allows that) and see if that helps :)

0
 
passion420Author Commented:
Actually this is happening with many users as  I know as of now. So its not settings for IE. may be something got changed on server which is why the sire is behaving like this. The internal site works fine and can connect to the site easliy.

What could be other possible reasons for sharepoint internet site to behave like this? Any thoughts? I did add a custom link list to home page today but I dont think that could be a problem. Please suggest. Thanks for your help.
0
 
jnbkzeCommented:
Hi There,

I think you may have overlooked what I said?

the internet facing site uses a FQDN. this is not negotiable. so therefore it acts differently within Internet explorer's built in settings.

Therefore, adding it to the trusted zone or local intranet zone, within Internet explorer - tools - internet options - security - intranet zone - sites - add. Will make a difference :)

If the internal site is eg, http://sharepointsitename and the external site is http://sharepointsite.peterpan.com then they are different in teh sense of using a netbios name, vs a fqdn. this impacts the security settings within internet explorer. - big time

esp newer versions of windows who may have enhances security enabled for the internet zone...

Please give it a try..
thanks
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Justin SmithSr. System EngineerCommented:
Do you use the same URL, inside and outside the network?

are you using kerberos?

is ISA or TMG involved?
0
 
passion420Author Commented:
Its working fine now. Not sure who changed what as our vendor company will not tell us what they did. For kerberos authentication if used shouldn't it ask for password both on intranet and internet? It only asked for password again and again on internet, intranet worked fine.
0
 
passion420Author Commented:
Never found the cause of this, but the suggestion that this happens due to Kerberos authentication may be possible,
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now