Blackberry phone using owa to connect to exchange 2007

we have to Blackberrys which use BIS to connet to Exchange via OWA , they worked fine with exchange 2003
we have changed to 2007 and we get incorrect password when we try to connect them .
Alan DuckAsked:
Who is Participating?
Alan DuckConnect With a Mentor Author Commented:
deleted the old setting and resetup
blackberries generally use a BES?? You will need to enable the service via your CAS server. Also as this is public facing it will need a proper SSL certificate and update to the External URL on your CAS.
Is your OWA working on this path

Please run this on exchange shell

Get-OwaVirtualDirectory -server SERVERNAME | Set-OwaVirtualDirectory -ExternalName -Exchange2003Url

then test it
go here from IE and see if you can login to OWA ?

then delete your old email from BIS and try to create it again.

Let me know if you are facing any issues.

I know this is not what you are asking for help with but in case you dont know the latest version of BES is free and has no additional expense for up to 75 users.  This will ultimately be the best option and give you the greatest control assuming it meets your requirements.

The hidden costs to this free software is the time you will spend learning and troubleshooting when there are issues and of course the hardware to run it on.  I have been successful getting it on low powered VM Machines for small environments and it hasnt caused issues at sites where its on a server sharing other duties but just plan carefully.
Try skipping the manual setup that uses the Exchange OWA URL and just try to configure it using your email address and password. The Exchange Autodiscover service may automatically configure things for you.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.