Blackberry phone using owa to connect to exchange 2007

we have to Blackberrys which use BIS to connet to Exchange via OWA , they worked fine with exchange 2003
we have changed to 2007 and we get incorrect password when we try to connect them .
Alan DuckAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DesertCrocCommented:
blackberries generally use a BES?? You will need to enable the service via your CAS server. Also as this is public facing it will need a proper SSL certificate and update to the External URL on your CAS.
0
sunnyc7Commented:
Is your OWA working on this path
https://mail.domain.com/owa

Please run this on exchange shell

Get-OwaVirtualDirectory -server SERVERNAME | Set-OwaVirtualDirectory -ExternalName https://mail.domain.com/owa -Exchange2003Url https://mail.domain.com/exchange

then test it
go here from IE and see if you can login to OWA ?
https://mail.domain.com/exchange

then delete your old email from BIS and try to create it again.

Let me know if you are facing any issues.

0
J0shJ0shCommented:
I know this is not what you are asking for help with but in case you dont know the latest version of BES is free and has no additional expense for up to 75 users.  This will ultimately be the best option and give you the greatest control assuming it meets your requirements.

The hidden costs to this free software is the time you will spend learning and troubleshooting when there are issues and of course the hardware to run it on.  I have been successful getting it on low powered VM Machines for small environments and it hasnt caused issues at sites where its on a server sharing other duties but just plan carefully.

http://na.blackberry.com/eng/services/business/server/express/
0
Shack-DaddyCommented:
Try skipping the manual setup that uses the Exchange OWA URL and just try to configure it using your email address and password. The Exchange Autodiscover service may automatically configure things for you.
0
Alan DuckAuthor Commented:
deleted the old setting and resetup
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.