Solved

Delegation to a group must be removed

Posted on 2010-08-14
5
396 Views
Last Modified: 2013-11-05
Goodmorning,
We have delegated a group to join computers to domain but, now, we need to remove that permission from every object.
I've tryed to deny writing permissions on that OU, but i see that they still have permissions to join old computer names to domain (wich were delegated to them.
Maybe with a script to remove this group from every computer object ? Exsists? Or there is something about permissions that could allow me to.. deny them? :)
0
Comment
Question by:Neurom
  • 3
5 Comments
 
LVL 57

Expert Comment

by:Mike Kline
ID: 33437171
How are you delegating, did you all do it through the delegation control wizard/ACLs or was it through  

Computer Configuration / Windows Settings / Security Settings / Local Policies / User Rights Assignment - "Add workstations to the domain"

Thanks

Mike
0
 
LVL 3

Author Comment

by:Neurom
ID: 33437236
Sorry, I didn't mentioning that, until now, we gave that kind of permission while adding every single computer to the domain, granting the permission to add workstations to the domain to that group.
Now, if i check security permissions of a computer name in AD, I see that group allowed to write on every object. I've tryied to put a "Deny" on the OU, but i've find out that it doesn't work, as the security on the single object "wins" on the inherited one.
0
 
LVL 3

Author Comment

by:Neurom
ID: 33439787
It seems that this question is more difficult of what i've expected. Points raised to 250.
0
 
LVL 39

Expert Comment

by:Krzysztof Pytko
ID: 33440520
OK, as I understood you delegated permissions for one group on OU, right? And now you want to remove that group?
If so, open your AD U&C console, navigate in menu to "View" and select "Advanced Features" option. Now, select proper OU and click right mouse button on it and choose "Properties". Select "Security" tab and locate that group which you want to remove. Select the group and click on "Remove" button then "OK". Now you shouldn't see that group on computer object's security tab.
0
 
LVL 3

Accepted Solution

by:
Neurom earned 0 total points
ID: 33441467
Sorry, as told "we need to remove that permission from every object", not just from the OU.
I've found a way by myself, using

DSACLS "ActiveDirectory Object DN" /R "Domain\GroupName"

However, thank you ;)
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows how to deploy dynamic backgrounds to computers depending on the aspect ratio of display
Last week, our Skyport webinar on “How to secure your Active Directory” (https://www.experts-exchange.com/videos/5810/Webinar-Is-Your-Active-Directory-as-Secure-as-You-Think.html) provided 218 attendees with a step-by-step guide for identifying Acti…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question