• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 589
  • Last Modified:

Installed VMware Server 1, now OWA & Outlook Anywhere doesn't work

Windows Server 2003 R2 64bit Standard
Exchange 2007
IIS 6

Installed VMWare Server 1 yesterday. Now Outlook Anywhere and OWA sites are not working. VMWare is configured to use the default ports of 8222/8333. IIS shows that all websites are running. But when I browse to https://server/owa I get a "Cannont display this webpage" error. Prior to the VMware install, it was working fine.
0
nexlynx
Asked:
nexlynx
  • 2
  • 2
  • 2
1 Solution
 
Shack-DaddyCommented:
VMWare added a bunch of additional virtual network adapters to your server. If I recall correctly, the Default Web site is configure to listen on all available IPs. I would change it so that it only listens on the IP belonging to your real NIC and then do an IISRESET and see if that resolves things.
0
 
SteveCommented:
try it locally on the server to make sure its working:
https://localhost/exchange (or /owa)

Before making suggestions as to the cause, we could do with some information on what the vmserver has to do with the network.
You advise it was working before the vm server. is the vm server an additional server to the exchnage one? if so, what roles does it have on the network. does the OWA on the exchange server work with the VMserver turned off?

If the vmserver IS the exchange server, could you advise in what format the server was succesfully working prior to being vm?
0
 
nexlynxAuthor Commented:
VMware server is installed on the same physical host hardware as Exchange. This is a new install of VMware. There are not guest OSMs installed yet. I can't reach the OWA site locally either. I'm not near the server at this time, so can't review the network adapter suggestions.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
Shack-DaddyCommented:
Another way to test and see if it is the virtual adapters is to shut down all VMWare services and then do an IISRESET and see if things start working. Shutting the services down should remove the virtual adapters (you can do an IPCONFIG while they are shut down to verify that), and then an IISRESET will let the Exchange vdirs initialize within the context of a simpler environment.

It may be that you want to set your VMWare services to Manual and only start them after everything else is online after a reboot, so that they aren't there when Exchange services start up. Alternately, you may find that setting the Default Website to listen on a single IP may help you avoid having to do that.
0
 
SteveCommented:
Ah-ha. The exchange server is also the vmhost!
Now i get it.
Thats putting a serious loa on an exchange server. Hope this is a seriously high spec server!
Anyway, check the exchange and iis services are all running as iis may have stopped at part of the vmware install.
Also, check in iis to see if owa is still there. Vmware could have taken over the 'default website'
if not, check you havent set vmware to take over control of the NIC. This ia good when the server has multiple NICs but rubbish if theres only one NIC.
0
 
nexlynxAuthor Commented:
Figured it out. The 32bit ASP.NET Framework 1.1 had been enabled for IIS. I needed to which it back to 64bit ASP.NET Framework 2.0. Here's the link to Microsoft KB, http://support.microsoft.com/kb/894435.

I should have picked up on this error earlier. I had a similar issues several months ago when installing another application. Thanks for all your suggestions. I'm uninstalling VMware Server.
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

  • 2
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now