exchange 2010 dag

We've set up a dag with 2 servers.  it's working fine but would like to set up replication on the second network adapter.   currently the replication nics which are on a separate subnet and showing unreachable.      I read that i have to put a static route in to the allow traffic between the replication networks.  

 

I saw on the microsoft article; http://technet.microsoft.com/en-us/library/dd638129.aspx where they specify

Route add 10.0.2.0 mask 255.255.0.0 10.0.1.254 -p



Where do they get the ip 10.0.1.254???  I have 2 separate subnets, one for my mapi network which is 10.100.0.0/22 which goes



through a router etc that is on that subnet. and then i have my replication network which i've just pretty much pulled out of thin

air. i don't understand how the replication network is suppose to communicate with each other.



I've read" http://www.shudnow.net/2009/10/29/exchange-2010-rtm-dag-using-server-2008-r2-%E2%80%93-part-1/ which was helpful

but doesn't mention anything about static routes.  It really seems that dags are very poorly documented. if i ever get

this darn thing working, i am going to jump for joy and may write something myself.



Anyway, i would really appreciate any help or suggestions. thanks so much.
techlindenAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Antonio VargasMicrosoft Senior Cloud ConsultantCommented:
First thing first. you need to configure a static IP address on both second nics of the DAG servers and be sure that you can ping then, from one server to another, on that ip's. The static route only applies because you cannot have two default gateways on the same server, and if the second NIC IP's on the DAG servers are on different subnets, you may need to create that route. So be sure that you create a route if you need and be sure that they can ping each other.
Second you need to go to the EMC->organization->mailbox->database avaiability groups and select each of the two servers. than you go to the dag networks on each server, and for the MAPI network you disable replication, leaving replication enabled on the replication netowork (you must see the two networks there). That should do the trick. When you have only one network and it's enabled for replication, DAG servers will use that network both to MAPI and replicate.
hope it helps
0
techlindenAuthor Commented:
I think i have to create a separate vlan for the replication network, don't i?    otherwise the replication network will not be able to communicate with each other, correct?
0
Antonio VargasMicrosoft Senior Cloud ConsultantCommented:
If you want to have 2 different subnets, one for MAPI and other for replication, you should have them to communicate. Do you have to create different VLANs? well it all depends on the configurations of your network? are both servers connected to the same switch? does that switch has vlans configurated? if you have a server connected to a switch, that for example has vlans configurated and associated to subnets, then introducing new subnets to the switch will force you to create a new vlan and associate that vlan to the 2 ports were both servers replication nics are connected. like i said you need 2 subnets, and if you need 2 vlans dependens on your network,.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

mukulagCommented:
All the above is correct.
1. You need to have to networks on your DAG
2. You need to have replication disabled on the MAPI network on your DAG to force replication on the replication network only. (Note that even of the replication netowork fails and replication is disabled on MAPI network, replication will still flow on MAPI network (MS Premium Support says this!!!))
3. As you can only have one Default gateway on a network and if the replication network is not routed, then you need to add the Static routes.
 
The catch is how you define the Static route. The command that you have given does not seem to be correct.  
1. You need to determine the MAC Address of the replication Interface first, then compare it to the output of the “Route Print” command.  At the top of the “Route Print” command, there is a section to tell you the Interface (IF) number of the replication network card by comparing the MAC Address.
2. Then use the appropriate route add command. Here is the command from my production environment.
 route add 10.1.28.0 MASK 255.255.255.0 10.235.48.1 METRIC 100 IF 14 –P
 Where 10.1.28.0 is the subnet of the replication interface of the other node of the DAG. 10.235.48.1 is the gateway to be used. OF is the Interface number identified by route print command. -P is for persistent route.
 

Temp.png
0
techlindenAuthor Commented:
then i think that answers my question.   the current configuration is one exchange server in a data center in Houston; one exchange server in an office in new york.   2 offices are connected via a cogent 100 m circuit.  there is a vlan that connects the 2 offices and 2 subnets (the mapi network) together.   So it sounds like i do have to create a second vlan for my replication network.  
0
mnevosoCommented:
how can i tell if my replication networks are replicating? i did the static routes as suggested. here is output for the following command Get-MailboxDatabaseCopyStatus MDB02 -ConnectionStatus | fl name, outgoingconnections,incomminglogcopyingnetwork

[PS] C:\Users\administrator.AFR\Desktop>Get-MailboxDatabaseCopyStatus MDB02 -ConnectionStatus | fl name, outgoingconnect
ions,incomminglogcopyingnetwork


Name                : MDB02\EXCHANGE02
OutgoingConnections :

Name                : MDB02\EXCHANGE01
OutgoingConnections : {{EXCHANGE02,MAPI}}

[PS] C:\Users\administrator.AFR\Desktop>Get-MailboxDatabaseCopyStatus MDB01 -ConnectionStatus | fl name, outgoingconnect
ions,incomminglogcopyingnetwork


Name                : MDB01\EXCHANGE02
OutgoingConnections :

Name                : MDB01\EXCHANGE01
OutgoingConnections : {{EXCHANGE02,MAPI}}
0
mnevosoCommented:
2 physical sites now also and i was able to get dag networks to work i believe as long as that output is correct.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.