Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

WAMP localhost problem

Posted on 2010-08-14
12
Medium Priority
?
2,547 Views
Last Modified: 2013-12-13
Hello,

I installed WAMPSERVER 2.0 on my laptop but when I browse to http://localhost/, a page running on IIS renders.

So, I did the following and it still did not work.
I opened up httpd.conf and made the following changes

Listen 80 -> Listen 8080
ServerName localhost:80 -> ServerName localhost:8080

When I browse to
http://localhost:8080/, it still does not work.

Any ideas of what I'm doing wrong?

Thanks!
0
Comment
Question by:Isaac
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
  • +2
12 Comments
 
LVL 7

Expert Comment

by:jhp333
ID: 33439105
Try this in httpd.conf:
BindAddress *

And I think you need to omit the ":8080" part of ServerName
0
 

Accepted Solution

by:
m3hran earned 1000 total points
ID: 33439108
these might seem stupid but they always get me.
1-make sure you refresh your browser on the page to make sure u see the active page and not the cached one.
2-make sure wamp set to online without any problem.
3-check the apache error log for erros to fix, copy and paste it here if u need help
4-check winwods application error logs for more details on errors and how to debug
5-make sure u not listening to poth ports on wamp
6-make sure there is a index.php/index.html files in c:\wamp\www

what are you getting when you browse to localhost:8080?
0
 
LVL 7

Expert Comment

by:jhp333
ID: 33439132
If it still doesn't work, run the following command in cmd window:

netstat -nap tcp  | find "LINSTEN"

and see if 127.0.0.1:8080 is listed.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 5

Author Comment

by:Isaac
ID: 33439230
Here's the error I get in IE.  
 The website declined to show this webpage  HTTP 403

Google chrome is a little bit more descriptive

Forbidden
You don't have permission to access / on this server.

Also, I browsed to "http://localhost:8080/phpmyadmin/" and it rendered to the page but there was an error at the bottom.  See image:
Capture.PNG
0
 

Expert Comment

by:m3hran
ID: 33439256
phpmyadmin is fine, that is normal.

things to check under httpd.conf

listen 8080
documentroot "c:/wamp/www" (index file in there)
<directory "c:/wamp/www/">

what do u have in c:/wamp/www? is it php or html?
does wamp show its online ? on the tast icon list next to the clock wamp should be solid white ?

did ur page originally show up on port 80 with out issues?

0
 
LVL 7

Expert Comment

by:jhp333
ID: 33439260
HTTP 403 - It's #6 of m3hran's list.

phpmyadmin issue is a separate problem. It's about the security settings of MySQL server. Follow the instructions on the screen - create a password for MySQL root account.
0
 
LVL 2

Assisted Solution

by:Tekati68
Tekati68 earned 1000 total points
ID: 33439378
Put all your settings back.

Go in to services and turn off the IIS Webserver and restart WAMP.

That will give you the least amount of grief going forward.
0
 
LVL 5

Author Comment

by:Isaac
ID: 33442570
If I turn of IIS webserver, will that affect me debugging in Visual Studio 2008?
Thanks
0
 
LVL 5

Author Comment

by:Isaac
ID: 33442597
I put all the settings back,turned off IIS and restarted Apache.

Now I get this error:

Forbidden
You don't have permission to access / on this server
0
 
LVL 13

Expert Comment

by:LinuxGuru
ID: 33452390
Hi,

Please check your apache log file for the exact reason. Sometimes it might be due to wrong permission / ownership of your files/folders.
0
 

Expert Comment

by:m3hran
ID: 33455825
also turn off windows firewall
0
 
LVL 5

Author Closing Comment

by:Isaac
ID: 33456762
In addition to all these things, I uninstalled WAMP and reinstalled it using my admin account.  Everything works great now.

Thanks.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you've heard about htaccess and it sounds like it does what you want, but you're not sure how it works... well, you're in the right place. Read on. Some Basics #1. It's a file and its filename is .htaccess (yes, with a dot in the front). #…
Many old projects have bad code, but the budget doesn't exist to rewrite the codebase. You can update this code to be safer by introducing contemporary input validation, sanitation, and safer database queries.
The viewer will learn how to count occurrences of each item in an array.
The viewer will learn how to create and use a small PHP class to apply a watermark to an image. This video shows the viewer the setup for the PHP watermark as well as important coding language. Continue to Part 2 to learn the core code used in creat…
Suggested Courses

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question