• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2414
  • Last Modified:

TightVNC/UltraVNC hangs after protocol negotiation

I just set up Ubuntu 10.04 Server and I'm trying to get RDP from Windows up and running.  I installed gnome with 'sudo apt-get install ubuntu-desktop', and I verified that vino is running on boot.  When I connect to the box with TightVNC, the status window hangs at "protocol negotiated".  I have to quit out using task manager.  UltraVNC does pretty much the same thing, but exiting the connection status window also exits the app.  The log for TightVNC is not very helpful, but is attached below.

Any ideas?


[2644] 2010-08-15 05:22:24 * Started and Winsock (v 2) initialised
[2644] 2010-08-15 05:22:24 + Buffer size expanded to 4352
[2644] 2010-08-15 05:22:24 * Registered connection with app
[2644] 2010-08-15 05:22:25 @ Connected to 10.0.0.8 port 5900
[2644] 2010-08-15 05:22:25     reading 12 bytes
[2644] 2010-08-15 05:22:25 @ RFB server supports protocol version 3.7
[2644] 2010-08-15 05:22:25     writing 12 bytes
[2644] 2010-08-15 05:22:25 @ Connected to RFB server, using protocol version 3.7
[2644] 2010-08-15 05:22:25     reading 1 bytes

Open in new window

0
Steve Bink
Asked:
Steve Bink
  • 4
1 Solution
 
Steve BinkAuthor Commented:
TightVNC and UltraVNC now connect, but only if a local console user is logged on to the GUI.  How can I configure the system to accept an RDP session including logon, instead of taking over an existing session?
0
 
TobiasHolmCommented:
Hi!

Found a solution for headless operation of VNC:

"
...need it to do is to add "gnome-session & to file /home/user/.vnc/xstartup

example;
#!/bin/sh

xrd $HOME/.Xresources
xsetroot -solid grey
#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &
gnome-session &
"

Ref: http://ubuntuforums.org/showthread.php?t=1172070&page=2

Also you could try NXClient from http://www.nomachine.com that should work with a headless system.

Regards, Tobias
0
 
Steve BinkAuthor Commented:
My apologies for the delay...my work schedule has been getting in the way of my experimentation.  I will get back to this by the weekend.
0
 
Steve BinkAuthor Commented:
I totally forgot about this question, and the need/curiosity has passed.  My apologies for the abandonment.  I do not have enough experience in this area to determine if the answer would have been helpful, but I'll award points all the same.  

0
 
Steve BinkAuthor Commented:
I was never able to get it working, and have no further time to spend playing with it.  I cannot testify as to the accuracy of the answer.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now