email stuck in submission queue exchange 2007

we have a new 2007 exchange server for some reason since friday  , al incoming emails are stuck in the submisson queue these include external and internal emails , have run Best Practises Analyzer which had no problems
Alan DuckAsked:
Who is Participating?
 
Alan DuckConnect With a Mentor Author Commented:
it appear the reason behind this problem was that the exchange hub transport servvice was logging on by the system account and as to be logon by network services account
0
 
Alan DuckAuthor Commented:
extra info the delivery type is undefined
0
 
ValutusCommented:
Is the "Exchange Transport Service" running?
0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
Razi_AhmedCommented:
what is the antivirus software you use ?
0
 
Alan DuckAuthor Commented:
the antivirus software is Sophos
the exchange transport service is running altough I have noticed that
a ) it has to be started manually even though it is set to automatic
b ) it takes quiet a time to stop and restart
0
 
SteveCommented:
do you use GFI mailessestials or another junk mail filter?
Could you have a look in event logs and let us know any warnings/errors you locate, particularly exchange ones.
0
 
Alan DuckAuthor Commented:
dont use any junk mail programs on the server
0
 
SteveCommented:
and the event logs? there must be a few warnings/errors logged?
0
 
Praveen BalanSolution ArchitectCommented:
Hi Mate,
Request you to share the event log details, enable the transport logging and see for indept logging. follow the steps below(you can iether use Shell or directly in registry). Only enable the trasport logging and for a reasonable period, save the log and run through it. There should be some leads.
http://technet.microsoft.com/en-us/library/bb201670(EXCHG.80).aspx

Also perform theb below steps, if you have not performed yet.
Stop all the AV services.
Restart transport and mail submission services.

-Praveen
0
 
Alan DuckAuthor Commented:
going to switch transport logging on now
there is no error in the event log which can be associated with the exchange except for a Microsoft Forefront Security error VSAPI library not registered
exchange transport log attached
MSGTRK20100814-1.LOG
MSGTRK20100815-1.LOG
0
 
Alan DuckAuthor Commented:
I need to unfreeze the submission queue anyone have the best solution
0
 
SteveCommented:
nice one. didnt see that coming!
0
All Courses

From novice to tech pro — start learning today.