Solved

Vmware server 2.0.2 new Virtual machine failed to power on

Posted on 2010-08-15
15
1,409 Views
Last Modified: 2012-05-10
I've installed VMware server 2.0.2 on a Dell R910 server which is running Windows 2008 64 bit+ sp2.
The newly created virtual machine always failed to power on and got below errors:
VMware Server unrecoverable error: (vmx)
Aug 16 00:11:05.636: vmx| NOT_IMPLEMENTED d:/build/ob/bora-203138/bora/vmx/main/hostWin32.c:809

Does anyone know what I did wong?
Many thanks.
0
Comment
Question by:brothertu
  • 8
  • 7
15 Comments
 
LVL 28

Expert Comment

by:bgoering
ID: 33440673
Please post your .vmx file and the vmware.log file for the failing vm.
Thanks
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33440707
I do see another post (http://blog.laksha.net/2009/10/vmware-workstation-unrecoverable-error.html) that indicates in some of the comments to be sure to run it as administrator. VMware server 2.x is about the same codebase as Workstation 6.x so you might try setting your service properties for VMware Server to run as the local adminsitrator account rather than local service and see what happens. With 2008, 2008 R2, Vista, Windows 7 there have been issues.

Looking at the HCL (http://www.vmware.com/go/hcl) it appears that Server 2.0.2 is only "Experimentally" supported on 2008 SP2 standard and enterprise, and not supported at all on Datacenter or Web versions

Good Lucki
0
 
LVL 1

Author Comment

by:brothertu
ID: 33440781
Thanks for quick reply. Please find attached vmx file and the log file.

By the way, I've configured th local administrator account as the log on account of all VMware services but it didn't make any difference.
0
 
LVL 1

Author Comment

by:brothertu
ID: 33440800
Sorry, file attached again.
vmx-and-log.zip
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33441092
Nice box! 6-core hyperthreaded processors?

Anyway - was this VM imported from an ESX(i) platform? I am surprised to see a ft.secondary0.enabled = "TRUE" in the vmx, along with a few other parameters.

You might try:

1. Rename your test08 folder
2. Generate a new Win2k8 vm as test08 without a disk drive. This should get a more compatible Server 2 vmx file
3. Move or copy the test08.vmdk file(s) to the new test08 folder. There may be a -flat.vmdk file, if so don't miss it.
4. Add a hard disk to your vm, select use an existing disk, and pick your test08.vmdk
5. Try to power it up

Good Luck - Let me know what happens
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33441108
Another thing you can try - if this is being moved from another VMware platform, try to do it as a V2V conversion using VMware converter, rather than copying the files. You may have to change the VM OStype on the source platform to Vista in order to get converter to like it. People have had issues with various flavors of converter on 2008 vms. Don't forget to change it back when you are done.
0
 
LVL 1

Author Comment

by:brothertu
ID: 33446470
Hi Bgoering,
Thanks for your replies.
The vm a newly created one from VMware server, not am imported one from ESX(i).
I've tried your suggestion, renamed the folder, created a new vm, copied vmdk files and then link it to the new vm, but still getting same error.

I've even tried to create a 32bit winXP vm, same result.
Any thoughts?
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 28

Expert Comment

by:bgoering
ID: 33446841
test - having trouble entering a response
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33447736
Trying it again. Looking at the VMware server user guide ( http://www.vmware.com/pdf/vmserver2.pdf ) I find:

"VMware Server hosts must meet the following requirements:
    Standard x86-compatible or x86-64-compatible server with up to 16 processors."

I am thinking you may be getting the NOT_IMPLEMENTED error because server is seeing 32 logical processors whereas, according to the documentation, it is only rated for 16.

Have you ever been able to power on a VM on this host? One thing to try is, again I am assuming you are running four 4-core CPUs with hyperthreading enabled, turn off hyperthreading. This would reduce the number of logical processors to match the number of physical cores and be within the limit of 16 for VMware server. Don't know if that is a long term solution, but it is something one could easily test.

A better solution, again in my humble opinion, would be to install ESXi directly on the R910. ESX(i) supports up to 128 logical processors and could better exploit your new system - probably much more effectively than your Windows 2008 SP2 that is running there now. Your Windows 2008 could always run as a VM under ESXi.

Let me know what you find
0
 
LVL 1

Author Comment

by:brothertu
ID: 33450288
bgoering,
Thanks for finding  out this:
"VMware Server hosts must meet the following requirements:     Standard x86-compatible or x86-64-compatible server with up to 16 processors."
If it's true, it will be bit of pain then as the reason why we purchased this server is due to some CPU intensive testing tasks and ESX(i) solution cannot meet our requirement since it only support max 8 vCPU on a single virtual machine.
Anyway I will test it and let you know the result.

Actually I have posted a related question  in regards to our special requirements and I am still waiting for some expertise with it:
http://www.experts-exchange.com/Software/Virtualization/Q_26386501.html

Maybe you can have a look at it so as to get better understanding our needs.
Thanks again.
0
 
LVL 1

Author Comment

by:brothertu
ID: 33450321
To answer your question:
Have you ever been able to power on a VM on this host?

No, I've just finished build of win2008 + vmware server 2 and that is the first vm I've created for testing.

BTW, the new server has 4 x 6-core CPUs and I can see 48 logic processors from the task manager.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33450994
I guess I figured out it was 6-core when I first looked at it - not sure why I thouht it was "only" 32 logical processors earlier today lol. Guess turning off hyperthreading won't do much good because there will still be 24 which is more than 16, so I would expect the same result.

I took a glance at your other thread - will the HPC cluster on ESXi not work for you? I am not a HPC expert, but see no immediate reason that it won't work.

Another thing you could try is VMware Workstation 7.1.1 - Free trial is available. Couldn't find any doc about what it will support in terms of number of cores - just that "mult-processor" systems are supported. And it is a couple generatious newer software than VMware Server 2.x

Good Luck
0
 
LVL 1

Author Comment

by:brothertu
ID: 33454078
I found this vmware kb:
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1008158

And I followed the instruction to server and replaced vmware-vmx.exe to a 32 bit one.
Then tried to power on the vm again. This time it doesn't crash but it just hang on 95% of powering on process, looks like frozen.
Tried another vm and got same result.

This is bizarre.
I think I might have to try Microsoft Hyper-v instead of VMware server.
What do you reckon?

VMware ESX(i), but for our special situation it's a pity that we can only stick on VMware Server.

I will test Hpyer-v then, instead of VMware station.
0
 
LVL 28

Accepted Solution

by:
bgoering earned 500 total points
ID: 33457135
The 95% hang often has to do with video or network drivers on the host system. Sometimes conflicting applications get in the way. I just participated in a long thread on this issue. See http://www.experts-exchange.com/Software/VMWare/Q_26404283.html

If you can ping the guest or rdp to the guest the network part is fine, just look at the video stuff. If this is a new guest that has DHCP to get its ip address, you can look at the "Edit Settings" screen of the network adapter to get the mac address, then look at your DHCP server to see what IP address was assigned to that mac address.

Good Luck
0
 
LVL 1

Author Closing Comment

by:brothertu
ID: 33607041
I've given up VMware and moved to Hyper-v.
thanks for all the help.
0

Featured Post

How does your email signature look on mobiles?

Do your employees use mobile devices to reply to emails? With mobile becoming increasingly important to the business world, it is in your best interest to make sure that your email signature looks great across all types of devices.

Join & Write a Comment

This is an issue that we can get adding / removing permissions in the vCSA 6.0. We can also have issues searching for users / groups in the AD (using your identify sources). This is how one of the ways to handle this issues and fix it.
In this article, I will show you HOW TO: Create your first Windows Virtual Machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, the Windows OS we will install is Windows Server 2016.
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now