[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 933
  • Last Modified:

USB backup drive always shows dirty bit turned on

Every morning our USB backup drive is rotated for the next day’s backup.  When Windows sees the new drive, We get a message that states “Do you want to scan and fix {drive} F:”.  If you select scan and fix, the drive is checked and reports no errors on the drive and that it is ready to use.  If you select not to scan the window closes.  In either case the backups run fine with no errors.
At this point, if the disk is ejected and the same disk is then remounted, no error message occurs but if you insert a different disk, the message appears again. After mounting and ejecting a different disk, If you put back the disk that was just scanned and fixed, the message appears again.
Using chkdsk F: /F and chkntfs F: here are the results:
Eject the Friday drive and put in Monday -> F: is dirty, chkdsk finds no problems, now F: is not dirty.
Eject and remount Monday -> F: is not dirty
Eject Monday and mount Tuesday –> F: is dirty, chkdsk finds no problems, now F: is not dirty.
Eject Tuesday and mount Monday -> F: is dirty

Since no data has been read or written to the drive in the 10 minutes it took to conduct this test, it is not possible that the physical drive is dirty. To narrow the source of the problem I disabled all of the Backup Exec services and performed the test again with the same results. When I try to stop the drive thru the Safely Remove Hardware window, the drive stops ok but has to be power cycled to be recognized by the system again.  Once power cycled, the drive does not show as dirty.

Why is the “dirty bit” getting set on these drives and /or how can I suppress the scan and fix messages?

System Overview:
 Dell PowerEdge R710, 64-Bit, 2.0Ghz Xeon E5504, 8Gb RAM
Windows SBS Server 2008 Standard, using Exchange
Dell RD1000 backup unit using 5 x 320Gb disks on a 5 day rotation
Device is set for quick removal, write cache disabled
Symantec Backup Exec 12.5, using removable backup to disk folders


0
THEarle
Asked:
THEarle
2 Solutions
 
noxchoGlobal Support CoordinatorCommented:
This is nature of Windows 2008 inherited from Windows Vista. All the drives are considered to be "dirty" by default.
Try to turn of autostart of the drive. As far as I know this should stop the scan and fix message from coming.
Another way to fix the problem is copying out data from this drive and completely reformatting the USB drive.
0
 
Davis McCarnOwnerCommented:
In typical M$ fashion, the top of this article doesn't list server 2K8; but, the body lists the specifics of disabling autoplay on 2K8: http://support.microsoft.com/kb/967715
What is causing your problem; though, is the fact that the volume serial numbers are different on each drive and, even though Dell has some nifty trick to make them appear as the same drive letter, Windoze knows they are different. In system management, are they showing as a removable media pool or as disks? If they are set as a removable media pool, that should solve your problem, too.
There are utilities which would let you make the volume serial numbers be the same; but, I'd be afraid to use them as it could easilly wreak havoc with BE and any volume caching being done by Windoze.
 
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Tackle projects and never again get stuck behind a technical roadblock.
Join Now