Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

remote desktops password not saved for some servers

Posted on 2010-08-15
2
Medium Priority
?
1,482 Views
Last Modified: 2013-11-21
Hi ,
I have a domain , 3 windows 2003 R2 , 8 windows 2008 R2,
I have install a remote desktops on my windows 7
and setup the remember credential for all servers.
the problem is , about 6 of the server are connected oK , but
5 of them I get this error and have to enter the password everytime.
Your credentials did not work
Your system administrator does not allow the use of saved credentials to log on to the remote computer terminal.server.com because its identity is not fully verified. Please enter new credentials.

Tried the solution on here http://itowns.blogspot.com/2009/01/remote-desktop-not-allowed-to-use-saved.html
but it doesnot works.

please help.
0
Comment
Question by:GordonLiq
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 3

Accepted Solution

by:
mchieff earned 2000 total points
ID: 33442382
2008 /Vista is weird in this area.
It is GP controlled but not the one you linked to.
Try this much more detailed fix:
http://alinconstantin.blogspot.com/2007_08_01_archive.html
0
 

Expert Comment

by:trusnock
ID: 34109341
Alin's blog referenced above got me most of the way to this solution--closer than any of the other solutions I had found.  Here are detailed steps for both a domain policy solution and a Windows 7 local policy solution that worked for us:

We are connecting from Windows 7 Pro to a standalone Windows Server 2008 machine (NOT in our domain) with RDP.  I had to set a policy on the local PC or local domain to "Allow Delegating Saved Credentials with NTLM-only Server Authentication".

I had tried half a dozen "solutions" provided in various blogs and websites, but none of them worked, and most of them provided steps that simply don't exist on my machines.  In the end, it was Alan Constantin's blog that lead me to the right answer, although the wording of the specific policy was different enough in his write-up for Vista to throw me off the trail with Windows 7 for an extra hour or two.

Anyway, here are two methods for making this work:

If you are on a domain and use a Domain Policy:

1. On your domain controller, click Start, Administrative Tools, Group Policy Management
2. (I edit my Default Domain Policy directly, which I've been told not to do, so forgive me)...
     Drill down to your domain, Group Policy Objects, Default Domain Policy (or whatever policy you want to apply this to).
3. Right-click on the policy and click Edit
4. Drill down to Computer Configuration, Policies, Administrative Templates, System, Credentials Delegation
5. Double-click "Allow Saved Credentials with NTLM-only Server Authentication"
6. Set thet policy to "Enabled"
7. Click the SHOW button in the policy and add the server you are connecting to to the list (out of frustration, I used "*" and that worked.  Click OK, OK
8. On your PC, at a command prompt, enter "gpupdate /force" to force the new policy to take effect.
9. Connect with RDP, entering your credentials one last time, remembering to check the box to save credentials.


If you are not on a domain, or do not use domain policies:

1. On your PC, click Start, run, gpedit.msc
2. Drill down to Computer Configuration, Administrative Templates, System, Credentials Delegation
3. Double-click "Allow Delegating Saved Credentials with NTLM-only Server Authentication" (notice the wording is different here than it was on the domain policy; I don't know why!)
4. Set thet policy to "Enabled"
5. Click the SHOW button in the policy and add your target server to the list (out of frustration, I used "*" and that worked.  Click OK, OK
6. At a command prompt, enter "gpupdate /force" to force the new policy to take effect.
7. Connect with RDP, entering your credentials one last time, remembering to check the box to save credentials.

0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
Group policies can be applied selectively to specific devices with the help of groups. Utilising this, it is possible to phase-in group policies, over a period of time, by randomly adding non-members user or computers at a set interval, to a group f…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
Suggested Courses

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question