Solved

External hard drive won't mount, cannot reformat

Posted on 2010-08-15
15
967 Views
Last Modified: 2013-11-14
My external hard drive won't mount, and I cannot reformat (greyed out).

Here's some info:
I volunteered my personal external hard drive for a backup at work.
After plugged into the server, the sys/admin said they could not get it to mount.
I removed the USB hard drive, but can no longer mount it on my PC (windows 7).
I could mount it to my PC prior to attaching it to the server.

I'm not sure what to do.

Images are attached.

Thanks!
devices.PNG
Disks.PNG
Hitachi-General.PNG
Hitachi-driver.PNG
Hitachi-Volumes.PNG
0
Comment
Question by:mralston2010
  • 4
  • 3
  • 2
  • +5
15 Comments
 
LVL 15

Expert Comment

by:Ian Meredith
ID: 33443066
I recommend trying/plugging in your USB Hard drive into 1 other PC (maybe Windows XP operating system).
If that also fails, I recommend removing the Hard Drive from the enclosure (yourself or by technician) and connecting the Hard Drive to a PC internally.  or
Get another USB enclosure and test Hard Drive in that.
I would suspect a fault within the enclosure (which would be Ok, as opposed to a fault with your Hard Drive - which wouldn't be Ok).
See how you go...
0
 

Author Comment

by:mralston2010
ID: 33443083
Do you think it could have anything to do with the sys/admin reformatting my external hard drive to a different file system?
0
 
LVL 15

Accepted Solution

by:
Ian Meredith earned 500 total points
ID: 33443098
Did he re-format it?  or is that a maybe....
If it was it could now be in EXT2/3 format (linux file system).... you will need 3rd party software (device driver) to recognise it under Windows 7.  try http://www.ext2fsd.com/
 
0
 
LVL 18

Expert Comment

by:web_tracker
ID: 33443102
It is possible that the server tried to format the drive to a ntfs file system, but you would have received a message asking for permission to format it to a ntfs file system. Not sure what kind of file system it was before.
0
 
LVL 15

Expert Comment

by:Ian Meredith
ID: 33443113
Have you tried setting up the hard disk from scratch -
1.  Delete existing partition
2. Create new partition on disk
3. Format partiton to NTFS format
Does it now work?
0
 
LVL 18

Expert Comment

by:web_tracker
ID: 33443139
If there is data on the drive I am sure mralston2010 does not want to delete the existing partition and recreate the partition and then format it. If he does he will lose all curent data on the drive.
0
 
LVL 3

Expert Comment

by:bfaruque
ID: 33443144
Is your OS is 64 bit? and what is the OS build. If it is 7077 or older then upgrade it as 7100. OR try to upgrade win7 RC1.

Check this link for fixing-
http://support.microsoft.com/kb/976972

also check this link for win7 with USB problem
http://windows7tips.us/USB_Problem.htm

Check this link too-
http://i.nconspicuo.us/2009/02/05/windows-7-not-recognizing-external-hard-drive-western-digital-mybook/
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 7

Expert Comment

by:jhp333
ID: 33443156
It seems the filesystem is gone. Maybe the sys admin tried to format it.
I also suggest Ian's solution, but I think formatting to FAT32 will be better for its better compatibility.
All 3 steps can be done at the screen of Disks.png, by right-clicking on the drive.
0
 

Author Comment

by:mralston2010
ID: 33443171
Ian_Admino: he said he coudn't keep it mounted, so I'm not sure if he had reformatted for LInux. It is possible. This was done about 3 months ago and he doesn't remember.

All: I'm okay with reformatting the drive. I removed all of my data prior to letting the sys/admin have access to it, so there will be no loss of data.

OS is 64-bit (windows 7)

I'll try Ian's solution tomorrow.
0
 
LVL 17

Expert Comment

by:sgsm81
ID: 33443775
Have you considered using partition magic or gparted to reformat the drive ?
0
 
LVL 3

Expert Comment

by:csalaski
ID: 33444547
From your included pics it looks like the drive is physically fine. However, because Windows does not support any filesystems other than fat and ntfs it cannot recognize nor read the filesystem on this drive.

What you see in Disk Management is what my Linux partitions which are EXT3 filesystems look to windows. I have attached a pic of my disk management.

This is not to say that someone has formatted the drives with a file system that Windows does not support, but it may mean that the file system is corrupted to the point that windows no longer can recognize it.

If there is the possibility that at some point it was formatted in some non-windows supported file system, then I would recommend downloading and burning a Linux Live CD such as Ubuntu, and booting with that just to check that drive. Linux Live cd's generally support many file system types.
Diskman.jpg
0
 
LVL 11

Expert Comment

by:ocanada_techguy
ID: 33446194
Just to be clear, in Disk Manager the right click option to Change/assign drive letter is also missing/greyed out?  (Probably, since the "type" is neither NTFS nor FAT32)
You could try using Run as Administrator Command Prompt DISKPART command-line tool.
Be careful with it, double-triple check you're working on the disk you intend to before invoking any commands that will change it.  Disk Manager may be more "novice friendly" but DISKPART will do what you tell it.  I think you'll find you can set the TYPE and/or remove and create partitions.

Before you do, make note of what numeric type value it thinks it is presently.

If you had data you wanted under it, I'd've suggested changing type and assigning volume a letter and nothing more than that.  You might try that and see if you can see the content.
If you still couldn't see your data, it might've been set as dynamic or formatted as some other "type" so, if you needed to try to get the data we then could try tools for file recovery after accidental formatting.  Experts report good success with recovermyfiles.com for accidental reformatting, and of course there is runtime.org GetDataBack, ontrack EasyRecovery, etc etc and other low-level reassemble from data blocks recovery tools.
0
 
LVL 11

Expert Comment

by:ocanada_techguy
ID: 33446363
True, I have seen Win Vista/7 is far more particular about partitions being in a "clean" state or else refusing to show them.  So Ian's suggestion of try attaching it to XP, believe-it-or-not, that often works, I've seen XP autocheck lots of disk activity and then voila the drive is back.  Seems an "improvement" in vista/7 so if anything about the partition or filesystem state does not jibe correctly well then to keep the user/system from mucking it up further (probably because VSS might use it regardless of whether the user makes any changes) it's just NO GO.
I've also seen this when attaching an XP active system boot drive to a Vista/7 system, it doesn't show it since it would not have correct ACL for it anyway, triggers the file settings transfer wizard only once, and from then on it doesn't show. I think vista/7 "improvement", again to prevent novice users from mucking things up, it doesn't like multiple active system partitions drives so will in a way hide the others.  Usually diskpart can get around it.
Also, Vista/7 try very hard to assign the same drive letter the volume had before, and if there's a conflict, would rather not give a drive letter than randomly change it the way XP would.

sgsm81 and csalaski are correct that PartedMagic boot CD can also mount and "see" the content of most drives, very useful for rescue.  That CD also has TestDisk on it, also useful.
0
 

Author Closing Comment

by:mralston2010
ID: 33492574
Worked great! Thanks!
0
 
LVL 15

Expert Comment

by:Ian Meredith
ID: 33497053
Glad to hear you have it sorted mralston2010 !
0

Featured Post

Save on storage to protect fatherhood memories

You're the dad who has everything. This Father's Day, make sure your family memories are protected. My Passport Ultra has automatic backup and password protection to keep your cherished photos and videos safe. With up to 3TB, you have plenty of room to hold the adventures ahead.

Join & Write a Comment

Solid State (Hard) Drives aka SSD began to evolve in the computer industry recently. As the name suggests, there are no moving parts in the drives. The drive uses microchip memory store the data, as opposed to the spinning disks of a traditional HDD…
Having issues meeting security compliance criteria because of those pesky USB drives? Then I can help you! This article will explain how to disable USB Mass Storage devices in Windows Server 2008 R2.
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now