what is this error?

while executing a sql query i got this error in toad:
ORA-6831047
st213497Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Guy Hengel [angelIII / a3]Billing EngineerCommented:
that's very suprising, as ORA- errors only have 5 digits.
so, it's a TOAD error (and you don't seem to be the only one having this issue)

you seem to have a toad version that is not 100% compatible with the server version/settings of some kind.
you can only make sure you get the correct versions, use another tool, or live with the problem  ,...
0
st213497Author Commented:
it is true i have a different version of road than the server .... but why this query only ...  and all the other queries run with no problem

SELECT * FROM RS@RIS_DB
           WHERE FINISH_TYPE in (0,1,2,3)
            AND  LENGTH(ROLL_ID)=6
         AND status =0
         AND roll_id in (100100,200200)
0
Guy Hengel [angelIII / a3]Billing EngineerCommented:
>FROM RS@RIS_DB
so, additionally, a query over dblink ... makes things not easier :)

can you try the same query from sql*plus (or some other oracle/sql tool)?

can you check if you get any user trace file on either db server?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

st213497Author Commented:
Actually i tried this from the same toad version but different database ... and i worked fine.
0
Guy Hengel [angelIII / a3]Billing EngineerCommented:
it would be know the puzzle to know what different setting between the 2 databases make up this error ...
0
slightwv (䄆 Netminder) Commented:
A quick Google shows that appears to be a Toad specific error.

It also appears to be related to a dropped connection.

http://tech.groups.yahoo.com/group/toad/message/53015

Since you can connect fine to a different database I suggest you look into network issues between your client machine and the server running RIS_DB.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
st213497Author Commented:
Thank you all.

it was the connection to the local DB not the remote one. I've reconnected to the local db once again and it worked.
0
Guy Hengel [angelIII / a3]Billing EngineerCommented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.