Solved

what is this error?

Posted on 2010-08-16
10
1,096 Views
Last Modified: 2013-12-19
while executing a sql query i got this error in toad:
ORA-6831047
0
Comment
Question by:st213497
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
10 Comments
 
LVL 143

Expert Comment

by:Guy Hengel [angelIII / a3]
ID: 33444526
that's very suprising, as ORA- errors only have 5 digits.
so, it's a TOAD error (and you don't seem to be the only one having this issue)

you seem to have a toad version that is not 100% compatible with the server version/settings of some kind.
you can only make sure you get the correct versions, use another tool, or live with the problem  ,...
0
 

Author Comment

by:st213497
ID: 33444559
it is true i have a different version of road than the server .... but why this query only ...  and all the other queries run with no problem

SELECT * FROM RS@RIS_DB
           WHERE FINISH_TYPE in (0,1,2,3)
            AND  LENGTH(ROLL_ID)=6
         AND status =0
         AND roll_id in (100100,200200)
0
 
LVL 143

Expert Comment

by:Guy Hengel [angelIII / a3]
ID: 33444595
>FROM RS@RIS_DB
so, additionally, a query over dblink ... makes things not easier :)

can you try the same query from sql*plus (or some other oracle/sql tool)?

can you check if you get any user trace file on either db server?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:st213497
ID: 33444624
Actually i tried this from the same toad version but different database ... and i worked fine.
0
 
LVL 143

Expert Comment

by:Guy Hengel [angelIII / a3]
ID: 33444677
it would be know the puzzle to know what different setting between the 2 databases make up this error ...
0
 
LVL 77

Accepted Solution

by:
slightwv (䄆 Netminder) earned 500 total points
ID: 33445062
A quick Google shows that appears to be a Toad specific error.

It also appears to be related to a dropped connection.

http://tech.groups.yahoo.com/group/toad/message/53015

Since you can connect fine to a different database I suggest you look into network issues between your client machine and the server running RIS_DB.
0
 

Author Comment

by:st213497
ID: 33445116
Thank you all.

it was the connection to the local DB not the remote one. I've reconnected to the local db once again and it worked.
0
 
LVL 143

Expert Comment

by:Guy Hengel [angelIII / a3]
ID: 34246288
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0

Featured Post

SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Working with Network Access Control Lists in Oracle 11g (part 1) Part 2: http://www.e-e.com/A_9074.html So, you upgraded to a shiny new 11g database and all of a sudden every program that used UTL_MAIL, UTL_SMTP, UTL_TCP, UTL_HTTP or any oth…
From implementing a password expiration date, to datatype conversions and file export options, these are some useful settings I've found in Jasper Server.
This video shows how to copy a database user from one database to another user DBMS_METADATA.  It also shows how to copy a user's permissions and discusses password hash differences between Oracle 10g and 11g.
This video shows how to copy an entire tablespace from one database to another database using Transportable Tablespace functionality.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question