Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Dbase program error handling

Posted on 2010-08-16
5
Medium Priority
?
622 Views
Last Modified: 2013-11-24
I have a Dbase utility program that reindexes files once a day.  It suddenly has been stopping on an error that says "language driver" mismatch and prompts you to fail, open read-only or reindex.  It always reindexes fine and I can't seem to resolve the language driver issue.

So how do you programatically trap or respond to this error and force the reindex without having any user interaction?
0
Comment
Question by:NAEDI
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 43

Expert Comment

by:pcelba
ID: 33445557
Such error message should be documented by the utility vendor. The only option when no documentation exists probably is to avoid conditions in which the error appears.

0
 

Author Comment

by:NAEDI
ID: 33445881
There is no vendor.  The utility program is just some DBase code, nothing third-party.  And the code simply calls these command for several tables.

USE EXTDTAIL INDEX EXTDTAIL
PACK
CLOSE ALL

USE EXTHEAD INDEX EXTHEAD
PACK
CLOSE ALL

USE EXTKBAN
PACK
CLOSE ALL
0
 
LVL 43

Expert Comment

by:pcelba
ID: 33446234
OK, and what says Dbase documentation about this error?

You should check code page and Windows regional settings used for this program. Do you use some non-US collation or order? Do you have all necessary NLS packs installed?

The solution could be following:
You should bring up the dBASE SE Desktop Properties dialog. If dQuery is open you must first close it. Then with focus at the command or navigator windows, the menu "Properties" should be displayed -- select this, and then select "Desktop Properties". In this dialog, make sure that the following settings are done:

Country tab, the Century checkbox should be checked (this is like typing SET CENTURY ON, and is used to display all four digits of the year in dates), and you may want to set Alert on mismatch off (uncheck it)
0
 
LVL 43

Accepted Solution

by:
pcelba earned 2000 total points
ID: 33446257
An alternate solution is  SET LDCHECK OFF issued in Command window. More info is here: http://www.dbase.com/Knowledgebase/faq/language_drivers.asp
0
 

Author Closing Comment

by:NAEDI
ID: 33446424
Thank you.  This is exactly what I was looking for.
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Technology opened people to different means of presenting information, but PowerPoint remains to be above competition. Know why PPT still works today.
Q&A with Course Creator, Mark Lassoff, on the importance of HTML5 in the career of a modern-day developer.
The viewer will learn how to create two correlated normally distributed random variables in Excel, use a normal distribution to simulate the return on different levels of investment in each of the two funds over a period of ten years, and, create a …
Progress

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question