Solved

Exchange 2010, OWA, Options doesn't work for 1 user

Posted on 2010-08-16
6
2,170 Views
Last Modified: 2012-05-10
I have 1 user (works for everyone else) that gets

You don't have permission to open this page. If you're a new user or were recently assigned credentials, please wait 15 minutes and try again.

The 2 fixes i've found in my searches are to delete and re-create the ECP, did that, didn't help.  The other was to verify the user had MyOptionsPage role, and he does.  

I am an Exchange Admin and can open any mailbox, and any other user click options fine, but with his mailbox I also get the same error.  Ideas ?
0
Comment
Question by:usmmsupport
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 33

Expert Comment

by:Busbar
ID: 33445299
did you check and made sure that allow inheritable permissions is selected for the user account
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33445343
if you migrated the mailbox from an older version of exchange you may need to run the following

Set-Mailbox user -ApplyMandatoryProperties
0
 

Author Comment

by:usmmsupport
ID: 33445346
It's not a user account issue.  Like I mentioned, I can't open Options if I open his mailbox via OWA either (i have full control of all mailboxes and can open Options on any other mailbox fine).  
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 53

Accepted Solution

by:
Will Szymkowski earned 500 total points
ID: 33445380
Take a look in the Event Viewer and see if there are any events that might lead to a more specific message. Try the following command...
Get-Mailbox {username} | Set-Mailbox –RoleAssignmentPolicy “Default Role Assignment Policy”

Also, have you tried to detach and re-attach your mailbox. Does this issue go away?
0
 

Author Comment

by:usmmsupport
ID: 33445396
Get-Mailbox {username} | Set-Mailbox –RoleAssignmentPolicy “Default Role Assignment Policy”

Worked !  Thank you very much !
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 33445406
Glad to help ;-)
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Find out what you should include to make the best professional email signature for your organization.
In-place Upgrading Dirsync to Azure AD Connect
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Suggested Courses

622 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question