Cannot receive mail on postfix server

I have a postfix server that cannot receive mail. I can send mail out using the webadmin interface but when I reply the email does not get delivered.
I had errors in the email log about "smtpd_recipient_restrictions": specify at least one working instance.." I changed the main.cf file to fix these (See attached) but now I am getting emails in the root mailbox like the code attached (Snippet ID=926721).

Hope this is clear, please let me know if I can provide any further information.
Thanks for any help.
Out: 220 my.server.com ESMTP Postfix (Debian/GNU)
 In:  EHLO external.server
 Out: 250-my.server.com
 Out: 250-PIPELINING
 Out: 250-SIZE 10240000
 Out: 250-VRFY
 Out: 250-ETRN
 Out: 250-ENHANCEDSTATUSCODES
 Out: 250-8BITMIME
 Out: 250 DSN
 In:  MAIL FROM:<personal@email.com> SIZE=2207
 Out: 250 2.1.0 Ok
 In:  RCPT TO:<me@my.server.com>
 Out: 451 4.3.5 Server configuration error
 In:  DATA
 Out: 554 5.5.1 Error: no valid recipients
 In:  QUIT
 Out: 221 2.0.0 Bye

Open in new window

// main.cf
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
program_directory = /usr/lib/postfix
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
setgid_group = postdrop
biff = no
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = $myhostname
mydestination = $myhostname, localhost
relayhost = 
mynetworks = 127.0.0.0/8
mailbox_command = 
mailbox_size_limit = 0
recipient_delimiter = +
append_dot_mydomain = no
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = 
	permit_mynetworks
	reject_unauth_destination
	check_relay_domains
smtpd_helo_required = yes
smtpd_helo_restrictions = 
	permit_mynetworks
	permit_sasl_authenticated
	reject_invalid_hostname
	reject_non_fqd_hostname
virtual_alias_maps = hash:/etc/postfix/virtual

Open in new window

LVL 1
kirkheaton25Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Barry GillChief of StaffCommented:
what is the setting for your local_recipient_maps?

try this:
Execute:
# grep warning: /the/maillog/file

See http://www.postfix.org/DEBUG_README.html#logging 
0
Barry GillChief of StaffCommented:
comments should go on their own lines, not at the end of a line.
smtpd_client_restrictions =
    # allow my networks
    permit_mynetworks
    # stuff that is here
    check_client_access hash:/etc/postfix/access
    # stuff that is here
    reject_unknown_client
    permit
0
Barry GillChief of StaffCommented:
sorry, I should have read that a bit clearer. Rules are processed in order, so you may want to move the deny rule to the bottom.
smtpd_recipient_restrictions =
      permit_mynetworks
      check_relay_domains
        reject_unauth_destination

Also check your DNS response times as failure on the below 2 (with **) will also cause an error
smtpd_helo_restrictions =
      permit_mynetworks
      permit_sasl_authenticated
**      reject_invalid_hostname
**      reject_non_fqd_hostname
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

kirkheaton25Author Commented:
Thanks, I am getting the following warnings -unknown smtpd restriction: "reject_non_fqd_hostname".
How would I check the DNS response times?
0
Barry GillChief of StaffCommented:
FQD = FQDN
fully qualified domain name
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Barry GillChief of StaffCommented:
sorry - even I missed that one :)
0
kirkheaton25Author Commented:
Yep, that's me feeling pretty foolish! Many thanks, it's all working now.
0
Barry GillChief of StaffCommented:
lol, me too, but an easy mistake to make :)

remember the saying that if all the letters are there your mind will fill in the rest... so it looked complete, thank goodness for log files :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.