Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Server 08 64bit - Slow Outlook Performance

Posted on 2010-08-16
8
Medium Priority
?
1,272 Views
Last Modified: 2012-05-10
Multiple Server 08 machines with Outlook 07 show the same problem...extreme latency to the exchange server. It takes up to 30-45 seconds to open an email of only 50kb. I've created my own virtual test environment and duplicated the reports.  This is only on Server 08 x64 machines. Everything works perfectly on all other OS's. Process explorer shows nothing out of the ordinary. CPU load is minimal and there's no other tasks or processes running that would slow things down.

I had the networking team look at the situation and the connection is just fine to the machine and to the exchange server. Ping test are just fine.

Previously performed troubleshooting:

 - Moved exchange data stores to different exchange servers (03 & 07)
 - Disabled Anti-virus
 - Updated Office with the most up to date updates and patches.
 - Checked AD group policies for issues.
 - Checked processes and server load.

Has anyone experienced anything similar to this? Microsoft phone support has been less than helpful.
Screen-shot-2010-08-12-at-3.18.3.bmp
0
Comment
Question by:jat0369
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
8 Comments
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 33449639
Remove the AV totally for testing.

Disable Large send offload, TCP Offload, IP Offload in your network card properties.

Disable TCP Chimney as well.

http://support.microsoft.com/kb/951037
0
 
LVL 1

Author Comment

by:jat0369
ID: 33454285
Thanks Dariusq...

I removed McAffe. I also did what you said regarding Offload and TCP Chimney. Unfortunately, I couldn't tell any noticable difference in the performance of outlook after reboot.

The following changes were made to the Network Adapter properties and via command line.

Here are the following properties under the network adapter on my VM test machine.
Interrupt Moderation - Enabled
IPv4 Checksum Offload - Disabled
IPv4 Giant TSO Offload - Disabled
IPv4 TSO Offload - Disabled
IPv6 TCP Segmentation Offload - Disabled
Jumbo Packet - Standard 1500
Large Rx Buffers - Not Present
MAC Address - Not Present
Offload IP Options - Disabled
Offload tagged traffic - Disabled
Offload TCP Options - Disabled
Proprity / VLAN tag - Priority & VLAN Enabled
RSS - Disabled
Rx Ring #1 Size - Not Present
Rz Ring #2 Size - Not Present
Small Rx Buffers - Not Present
Speed / Duplex - Auto Negotiation
TCP Checksum Offload (IPv4) - Disabled
TCP Checksum Offload (IPv6) - Disabled
TX Ring Size - Not Present
UDP Checksum Offload (IPv4) - Disabled
UDP Checksum Offload (IPv6) - Disabled
VLAN ID - Not Present
Wake-on-LAN - Enabled
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 33457282
Have you removed the Team? Updated firmware and drivers?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LVL 1

Author Comment

by:jat0369
ID: 33457597
My VM test environment doesnt have NIC Teaming. Firmware and drivers...all up to date.
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 33457608
So, this is the only VM having issues?
0
 
LVL 1

Author Comment

by:jat0369
ID: 33459132
No, I set up a test environment up because originally the problem was discovered on a production citrix server. I wanted to isolate all other variables from the situation so I created this VM running the same OS and installed Office. That's it.

This is affecting multiple servers.
The only thing they have in common is Windows Server 08 x64.
0
 
LVL 59

Accepted Solution

by:
Darius Ghassem earned 2000 total points
ID: 33459173
0
 
LVL 1

Author Comment

by:jat0369
ID: 33466293
Disabling Autotuning did the trick!
Duplicated the fix on the virtual machine as well as the production server and the fix was immediate!

Thanks DariusQ. You just made my day!
Not only did this fix the problem, I'm getting my money back from Microsoft support since they didn't fix it!

Woo Hoo!
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
New style of hardware planning for Microsoft Exchange server.
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question