adding Linked server for AS400

I am trying to add a linked server for our AS400 to use with SQL 2005. So far I have not been sucessful. I am attaching what I entered and the error I received. Any help will be greatly appreciated. as400-Linked-Server-error.docx
qbjgqbjgConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

qbjgqbjgConsultantAuthor Commented:
I did not find anything there that helps. I am trying to fill out the screen correctly.
0
MeLindaJohnsonCommented:
Did you check to see if the "allow in process" has been checked?
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

qbjgqbjgConsultantAuthor Commented:
What screen is that on?
0
MeLindaJohnsonCommented:
I use SQL 2008 so it may be the same

Using Management Studio,
expand linked servers,
expand providers
right click on your provider,
check Allow inprocess

Hope this helps...
0
qbjgqbjgConsultantAuthor Commented:
It is already checked.
0
qbjgqbjgConsultantAuthor Commented:
Is there an easy way to get the correct provider string?
0
MeLindaJohnsonCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
qbjgqbjgConsultantAuthor Commented:
I was finally sucessful. I am attaching a document with what I did. Thanks for all of your help. It was trial and error until I got it working (along with help from google).
Setting-up-Linked-server-to-AS40.docx
0
qbjgqbjgConsultantAuthor Commented:
See also my notes on how the linked server was sucessfully created on our system.
Thanks for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IBM System i

From novice to tech pro — start learning today.