• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 424
  • Last Modified:

adding Linked server for AS400

I am trying to add a linked server for our AS400 to use with SQL 2005. So far I have not been sucessful. I am attaching what I entered and the error I received. Any help will be greatly appreciated. as400-Linked-Server-error.docx
0
qbjgqbjg
Asked:
qbjgqbjg
  • 6
  • 3
1 Solution
 
qbjgqbjgConsultantAuthor Commented:
I did not find anything there that helps. I am trying to fill out the screen correctly.
0
 
MeLindaJohnsonCommented:
Did you check to see if the "allow in process" has been checked?
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
qbjgqbjgConsultantAuthor Commented:
What screen is that on?
0
 
MeLindaJohnsonCommented:
I use SQL 2008 so it may be the same

Using Management Studio,
expand linked servers,
expand providers
right click on your provider,
check Allow inprocess

Hope this helps...
0
 
qbjgqbjgConsultantAuthor Commented:
It is already checked.
0
 
qbjgqbjgConsultantAuthor Commented:
Is there an easy way to get the correct provider string?
0
 
MeLindaJohnsonCommented:
0
 
qbjgqbjgConsultantAuthor Commented:
I was finally sucessful. I am attaching a document with what I did. Thanks for all of your help. It was trial and error until I got it working (along with help from google).
Setting-up-Linked-server-to-AS40.docx
0
 
qbjgqbjgConsultantAuthor Commented:
See also my notes on how the linked server was sucessfully created on our system.
Thanks for your help.
0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now