Perl missing module (:MODULE_COMPAT_5.8.8)

I'm trying to install a missing module for Perl 5.8.8 on my SLES10SP3 it's the perl-Module-compat which is needed by munin-common-1.4.5. I've tried to install it with cpan and searched for a rpm, both with no result.

install error: rpm -i munin-common-1.4.5-2.el5.noarch.rpm - error: Failed dependencies:
        perl(:MODULE_COMPAT_5.8.8) is needed by munin-common-1.4.5-2.el5.noarch

Does any one have any experience with this?

Thanks in advance for your help

Greetz,
Marcel.
marcel_ramakerAsked:
Who is Participating?
 
marcel_ramakerConnect With a Mentor Author Commented:
Just tried the the older version, installing went smooth.

Thanks for your time and input.

Greetz,
Marcel.
0
 
samdartCommented:
Check your perl version.

Is it 5.8.8 or higher?
0
 
marcel_ramakerAuthor Commented:
Yast reports 5.8.8-14.10 - It's a first time install for munin, so I download this version. Meanwhile I've found something on the Novell Forums to install version 1.2.5-4.1. Could try this one, but have no clue of the differences between those.

Marcel.
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
samdartCommented:
Looks like you are installing a RHEL or Vemula package and sometimes dependencies might not match
0
 
samdartCommented:
Looks like you are installing a RHEL or Vemula package and sometimes dependencies might not match
0
 
marcel_ramakerAuthor Commented:
That thought has crossed my mind, because of the el5 in the package-name. Probably only has to do where files will be put. But ... you might be right:)
0
 
arnoldCommented:
perl -MCPAN -e 'install packagename" will go through the configuration/install process including retrieving and installing any dependencies.
0
 
marcel_ramakerAuthor Commented:
@arnold: tried that one; did not work. In none of the mirrors it's available. You need a RPM for this.

But thanks for the sugestion:)
0
 
arnoldCommented:
The strange thing is that you have SLES10 yet you downloaded and tried to install a RedHat package.

http://www.novell.com/coolsolutions/feature/17913.html

In case you plan on getting/installing the newer version:
http://sourceforge.net/projects/munin/files/
0
 
marcel_ramakerAuthor Commented:
That's what samdart also pointed out, and was aware of that. Did look @ the munin files on sourceforge, but no packages for sles10 unless I compile the source for it. And I did, with the same results ... missing dependencies for :module_compat_5.8.8.

Set up a vm with OpenSuse 11.3, no problem at all! So I guess it all has to do with a number of outdated packages on the SLES10SP3 distro.

Thanks again,
Marcel.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.