?
Solved

Reporting services error - cannot create a connection to datasource

Posted on 2010-08-16
7
Medium Priority
?
706 Views
Last Modified: 2012-05-10
I have developed few reports and have provideed the browser level access to few users. Everything was working fine until few hours ago. Suddenly, after I deployed the reports after adding new reports and modifying few existing reports, all my users are getting the error shown in the screen shot file below. What has changed and how to fix this:
rs-Error.JPG
0
Comment
Question by:skaleem1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
7 Comments
 
LVL 5

Expert Comment

by:robertg34
ID: 33450333
Redeploy your datasource and the error should clear.  If you are using stored credentials in the datasource, you may have to re-enter those from the reporting services web page interface.  
0
 
LVL 1

Author Comment

by:skaleem1
ID: 33451013
Redeployment did not help. Can you tell me how to re-enter stored credentials in the datasource from the reporting services web page interface.
0
 
LVL 5

Accepted Solution

by:
robertg34 earned 2000 total points
ID: 33451052
If you don't see your data sources, there should be a link to show 'all' on the main report page.  Click that and look for your data source, click the data source and choose properties.  Within that will be the options to store your credentials.  That is if the credentials were stored in the first place.  That's a known issue a lot of folks have.  
 
0
Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

 
LVL 1

Author Comment

by:skaleem1
ID: 33454504
I tried editing the datasource from BI and found out that I am using Windows Authentication -so no credentials required. Any clues?
0
 
LVL 1

Author Comment

by:skaleem1
ID: 33454546
another thing to notice, I can access it locally from the report server as well as from my laptop computer using the web app. that calls the report link. But non of the other users can access the report.
0
 
LVL 1

Author Comment

by:skaleem1
ID: 33457739
Here is how it was resolved-as you pointed out in your answer. I am adding a detailed walk through so that anyone going through this issue does not waste time that way I did :-)
 
Step 1: Add a New Report User - Go to SQL Server Management Studio- Connect to the Database Server -Database Engine- Expand the Security folder - right click on Logins Folder - Select New Login and add a new User called ReportUser. Login - New dialog box opens - Enter a new login name (say) ReportUser, select SQL Server Authentication and provide password. In the left pane, select User Mapping link and check the database(s) you want to provide the access in the upper right pane and the data role membership in the lower right plane and click OK.

Step 2- Update the Data Source: From SQL Server BI Development Studio, go to the report.rdl file Data view, click on the eclipse on the right of the Dataset- Dataset dialog box opens-on the Query tab click on the eclipse on the right of the data source selected in the dropdown list-Data Source Dialog box opens up-in my case "Use shared data source reference" is checked as I am using the shared data source- click on the Edit button located on the RHS of the data source reference selected in the dropdown list - Shared Data Source dialog box opens up - in the General tab, click on the edit button located on the right hand side of the Connection String text box- Connection Properties dialog box opens up - change the "Use Windows Authentication" option to "Use SQL Server Authentication", provide the user name and password and check the "Save my password" checkbox. Click on the Test Connection button on the bottom of the dialog box to make sure that the connection succeeds and click OK-OK-OK-OK.

Step 3: Set OverWriteDataSources property to true (in case we are deploying within the same environment) From SQL Server BI Development Studio, go to the Solutions Explorer, right click the Reports project and select properties - Properties page opens - In the right pane, make sure that OverWriteDataSources property is set to true.

This will resolve the above error and all users will be able to access the reports through a single user we just created named "Reports User"

Thanks
0
 
LVL 1

Author Closing Comment

by:skaleem1
ID: 33457769
Thanks for your help, but pls try to elaborate a little more for novices like me
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have a large data set and a SSIS package. How can I load this file in multi threading?
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Via a live example combined with referencing Books Online, show some of the information that can be extracted from the Catalog Views in SQL Server.
Viewers will learn how to use the INSERT statement to insert data into their tables. It will also introduce the NULL statement, to show them what happens when no value is giving for any given column.
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question