?
Solved

SQL 2008 Connection Failed when connecting through ODBC

Posted on 2010-08-16
9
Medium Priority
?
809 Views
Last Modified: 2012-05-10
Connection failed:
SQLState: '01000"
SQL Server Error: 2
[Microsoft] [ODBC SQL Server Driver][Shared Memory]
ConnectionOpen (Connect ()).
Connection failed:
SQLState: '08001'
SQL Server Error: 17
[Microsoft][ODBC SQL Server Driver][Shared Memory]SQL Server does not exist or access denied.

I'm at a loss. This is a named instance, not listening on port 1433.  I can connect to the database in the management studio with no problem. Any help would be appreciated.
0
Comment
Question by:ITGhost
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +2
9 Comments
 
LVL 1

Expert Comment

by:Wiebren
ID: 33450072
Have you tried turning off the firewall for minute to see if thats the issue ?
0
 
LVL 1

Author Comment

by:ITGhost
ID: 33450096
I have turned off the Firewall, but tried immediately afterward.  This is on a single server, however.
0
 
LVL 7

Expert Comment

by:lundnak
ID: 33450130
Please make sure that Shared Memory is turned on for the Client Protocols on your SQL Server.

1. Open SQL Server Configuration manager
2. Browse to SQL Native Client x.xx Configuration
3. Click on Client Protocols.

Are Shared Memory, TCP/IP, and Named Pipes enabled?
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 
LVL 1

Author Comment

by:ITGhost
ID: 33450139
All three are enabled.
0
 
LVL 8

Expert Comment

by:Julianva
ID: 33452236
when you create your odbc in servername dialog do this

servername/instance,portnumber - eg testserver/testdb,3306


you must specify port number when you have changed from default. Use the tcp protocol seems like you using named pipes, because named pipes uses shared memory.PLEASE MAKE SURE YOU  ARE USING THE CORRECT INSTANCE NAME - common mistake when using named instances. look in services for correct instance name if not sure



0
 
LVL 2

Accepted Solution

by:
dhlotter earned 2000 total points
ID: 33453772
try connecting through odbc datasource by specifying your servername like this

servername\instancename   (note the backslash)

in the client configuration, make sure you have TCP/IP selected and that the server alias and server name are both the same as the format above. also have 'dynamically determine port' enabled.

this should do the trick.
0
 
LVL 8

Expert Comment

by:Julianva
ID: 33453870
dhlotter
the backslash is quite right, mistake in my comment.

0
 
LVL 1

Author Closing Comment

by:ITGhost
ID: 33455316
Thanks for this answer.
0
 
LVL 2

Expert Comment

by:dhlotter
ID: 33461566
pleased we could help
0

Featured Post

Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we will learn how to fix  “Cannot install SQL Server 2014 Service Pack 2: Unable to install windows installer msi file” error ?
It is possible to export the data of a SQL Table in SSMS and generate INSERT statements. It's neatly tucked away in the generate scripts option of a database.
Via a live example, show how to extract information from SQL Server on Database, Connection and Server properties
This videos aims to give the viewer a basic demonstration of how a user can query current session information by using the SYS_CONTEXT function
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question