Solved

Connecting Outlook to an Exchange account hosted overseas

Posted on 2010-08-16
13
499 Views
Last Modified: 2012-05-10
Hi,

One of my clients has their main office in Malaysia and their server  (including Exchange server) is managed by a local IT company. They also have a small office in another countrty, with 2 users. I am trying to setup Microsoft Outlook for these 2 users, but cannot get it to connect or lookup the names.

Note, both users are just using Local accounts, they are not a part of any domain. Not that it should matter...?

I have all of the relevant details, Exchange server name, usernames, passwords, HTTP proxy connection address etc. But I still receive the error :

 "The name could not be resolved. The connection to Microsoft exchange server is unavailable. Outlook must be online or connected to complete this action"

Yet, both users can access webmail for the account just fine.

Am I missing a really obvious detail? I have setup Exchange account for many clients many times. I have had success setting up an account on both of these PC's with a local Exchange server (a different domain, just for testing purposes).

0
Comment
Question by:samfpt
  • 6
  • 4
  • 2
  • +1
13 Comments
 
LVL 24

Accepted Solution

by:
B H earned 334 total points
ID: 33451765
can you run this test as the users:
https://www.testexchangeconnectivity.com/

anything useful come back there?
0
 

Author Comment

by:samfpt
ID: 33451796

Bryon, great testing tool thank you. Results as follows:

 ExRCA is testing RPC/HTTP connectivity.
  The RPC/HTTP test failed.
   Test Steps
   Attempting to resolve the host name mail.greatshipglobal.com in DNS.
  Host successfully resolved
   Additional Details
  IP(s) returned: xxx.xx.xxx.xxx
 
 Testing TCP Port 443 on host mail.greatshipglobal.com to ensure it is listening and open.
  The specified port is either blocked, not listening, or not producing the expected response.
   Tell me more about this issue and how to resolve it
   Additional Details
  A network error occurred while communicating with remote host
Exception details:
Message: No connection could be made because the target machine actively refused it xxx.xx.xxx.xxx:443
Type: System.Net.Sockets.SocketException
Stack trace:
at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
at Microsoft.Exchange.Tools.ExRca.Tests.TcpPortTest.PerformTestReally()
 
 
 
 
0
 
LVL 24

Assisted Solution

by:B H
B H earned 334 total points
ID: 33451824
ok so they're not using secure SSL - try running the test again but tell it to not use or care about SSL
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:samfpt
ID: 33451846
There isn't an option to specifiy not using SSL.

But to clarify, I'm selecting the option 'Outlook Anywhere (RPC over HTTP) '

and specifying the server option manually.

Using the Autodiscover option also failed
0
 
LVL 24

Assisted Solution

by:B H
B H earned 334 total points
ID: 33451855
hmmmmm i wonder if that's the problem.... autodiscover

as a test, can you edit the client workstation like this:
start > run > notepad.exe (run as administrator if not xp)
file > open
c:\windows\system32\drivers\etc\hosts
(hosts is the file, no extension)

at the bottom add this like:

0.0.0.0 autodiscover.greatshipglobal.com
(that's a tab after the last zero)

save it

then do start > run > cmd
ipconfig /flushdns

try your outlook again.

sometimes outlook gets real freaky with autodiscover - this effectively neuters it
0
 

Author Comment

by:samfpt
ID: 33451931
Bryon,

Unfortunately not. I followed those steps to the letter, but no different.

Any other thoughts?

I've had the same issue with a totally different client, Exchange server based local to me, client office in Malaysia (opposite to current issue) and have the same problem...

Surely there must be something missing here?
0
 
LVL 3

Expert Comment

by:raxix
ID: 33452172
Can you try with the IP address of the exchange server instead of the name
0
 

Author Comment

by:samfpt
ID: 33460475
IP also doesn't work
0
 
LVL 24

Assisted Solution

by:B H
B H earned 334 total points
ID: 33460665
well you could always try starting outlook as:
start > run > "outlook /rpcdiag"  (no quotes)
and see if anything useful comes out

0
 

Assisted Solution

by:Joh_wel
Joh_wel earned 166 total points
ID: 33463181
Hi samfpt,

Is the router or firewall at the client's site set up to forward all http and https traffic to the Exchange server?
0
 

Author Comment

by:samfpt
ID: 33471240
Presumbably... we can access webmail perfectly....

0
 

Assisted Solution

by:Joh_wel
Joh_wel earned 166 total points
ID: 33473383
Try to connect with VPN. I do so for my client, who also have to work remotely to Exchange. If you can connect to Outlook inside the client's office, I think there is no need to do anything further to Outlook, just set up VPN.
0
 

Author Closing Comment

by:samfpt
ID: 33592798
In the end it was to do with the Security Certificates, they weren't installed in the correct directory, they needed to be in the 'Trusted Root Certification Authorities" directory.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What does UTC stand for?  “Coordinated Universal Time” – Think of this as the true time on Planet Earth that never changes with the exception of minor leap seconds here and there to account for the changes in the planet's rotation.   What does th…
When you have clients or friends from around the world, it becomes a challenge to arrange a meeting or effectively manage your time. This is where Outlook's capability to show 2 time zones in one calendar comes in handy.
This video discusses moving either the default database or any database to a new volume.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question