Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 288
  • Last Modified:

Cannot set Word association

If I right click a .doc file, select "open with" / browse and navigate to winword.exe (which is in C:\Program Files\Microsoft Office\Office12) when I  select winword.exe  and click "Open" the dialogue box closes but nothing else happens and the association for .doc files stays set to swwriter.
0
cgaski
Asked:
cgaski
  • 8
  • 3
  • 2
  • +1
1 Solution
 
danubianCommented:
Launch Office Setup and select repair.
0
 
cgaskiAuthor Commented:
If I run the original set up file, X12-30107.exe, and select "repair" I get, "Cannot find office.en.us\Setup.xml.  Browse to a valid installation source and then click OK".  If I browse to the folder containing the installation file it says there is no valid file.
0
 
andrewglendeanCommented:
you may have a registry issue. try this.
Repair Word (Office)
Word can detect and repair problems associated with Setup. This feature uses the Windows Installer to correct problems with missing files and to repair registry settings.

You can use the following three methods to repair or to reset Word files and values:

    * Method 1: Use the "Detect and Repair" feature
    * Method 2: Repair Word in Maintenance Mode Setup
    * Method 3: Reinstall Word (Office)
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
cgaskiAuthor Commented:
Where do I find the "Detect and Repair" feature?
0
 
cgaskiAuthor Commented:
OK, I found the " Detect and Repair" feature.  It found one error and corrected it but still the file association doesn't work.
0
 
Chetan KhuranaTechnical ManagerCommented:
Hi @cgaski

I am assuming that you are using Windows version >= XP - (For Windows 7, please follow this link - http://vista.blorge.com/2009/10/26/how-to-change-file-type-associations-in-windows-7/)

Follow this:
 - Go to Windows Explorer Menu -> Tools -> Folder Options;
 - Click on File Types TAB
 - Scroll down to DOC extension;
 - Select DELETE button.
 - Confirm, Press OK, and come out of the dialog window;

 - Now navigate to any .doc file.
 - Double click. It will ask for association. Give it the path for the winword.exe.

 - close the file, and check again.

It should be working now. Please post back the results

Regards,

CK
0
 
cgaskiAuthor Commented:
Actually I'm using Windows 7

If I follow the instructions in the link you provided I am taken into the same dialogue that is accessed by right clicking a file and selecting, " Open with" and the results are the same.

Unlike XP I can't find any way of deleting an association.
0
 
danubianCommented:
It seems Word isn't registered correctly.

In regedit: Navigate to Computer\HKEY_CLASSES_ROOT\Applications and find your .exe name.  Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable, hit ok and then try and reassociate the file type as you normally would.
0
 
cgaskiAuthor Commented:
I'm always very nervous when messing about in the registry.

I can get as far as:

"Navigate to Computer\HKEY_CLASSES_ROOT\Applications and find your .exe"

but I don't know how to do the next bit:

"Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable"

Could you provide some more detailed instructions?
0
 
Chetan KhuranaTechnical ManagerCommented:
Hi @cgaski,

This should help you out.

http://www.mydigitallife.info/2008/06/20/how-to-unassociate-file-types-and-remove-file-extension-associations-in-windows-vista/

Follow the instructions to remove the association and then reassociate by double clicking the .doc type and seleting the Winword prog.

Tell me what happens
Best of Luck!
C
0
 
cgaskiAuthor Commented:
I can complete the disassociation but I am unable to set a new association.

The problem is that winword is not among the choices presented and when I browse to winword.exe and click open nothing happens.  I can open a doc.exe file by dragging and dropping it on to Word.
0
 
cgaskiAuthor Commented:
I meant a .doc file.
0
 
danubianCommented:
See attached example for shell>open>command, and change app default folder accordingly your Word location.
Capture.JPG
0
 
cgaskiAuthor Commented:
That's fixed it!

Thanks for going to the trouble to send me the pic.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 8
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now