Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

connect HP procurve 2910al switch to cisco router

Posted on 2010-08-17
10
Medium Priority
?
1,579 Views
Last Modified: 2012-05-10
we have a 2910al switch that needs to connect to a cisco router. We have been given instructions to configure a port on our switch to talk to the router, but these are instructions for another cisco switch not a HP one. The instructions are as follows...
config t
port 23
description***Connection to Orange router-Fa0/1***
no switchport
ip address 10.xx.xxx.xxx 255.xxx.xxx.xxx
no ip redirects
no ip proxy-arp
speed 100
duplex full
no shut
ip route 10.xx.xx.x 255.xxx.xxx.xxx.x 10.xxx.xxx.xxx
end
Is this possible to do with a 2910al switch - I think it maybe but not sure if I have to do a vlan???  
0
Comment
Question by:chriswilson265
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +2
10 Comments
 
LVL 3

Expert Comment

by:Xenix
ID: 33453193
I don't have a HP switch handy to test it out on but HP and Cisco CLI are very close to each other, if you have a little bit of experience with either you should be able to turn that Cisco config into a HP one, commands may be placed slightly different in menus or be named slightly different, but it should definately be doable.
Using the help and auto-complete features ("?" and tab, if memory serves) will definately also make your life easier.

I see nothing in the config that indicates that a VLAN should be necessary to make the connection work.
0
 
LVL 34

Assisted Solution

by:Istvan Kalmar
Istvan Kalmar earned 1000 total points
ID: 33453229
Hi,

it is possible:

ip routing
vlan 1
 ip add x.x.x.x x.x.x..x
vlan 2
 untagged 23
 ip address 10.xx.xxx.xxx 255.xxx.xxx.xxx

ip route 10.xx.xx.x 255.xxx.xxx.xxx.x 10.xxx.xxx.xxx
0
 
LVL 3

Expert Comment

by:Xenix
ID: 33453481
Sure it is possible, but your original configuration does not mention VLANs anywhere, so I don't see what leads you to believe you need a VLAN to make it work?

As I understand it port 23 will be the one connected to your Cisco router, right? Unless it is configured with vlan 2 I see no reason to untag it on port 23, maybe you could post the configuration for the port on the Cisco router that this switch will be connected to?
0
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 

Author Comment

by:chriswilson265
ID: 33454110
hi all, I want to perform L3 routing on the port 23 on the switch. from my limited knowledge, I know that you can create a vlan and give this an IP address and also would have to setup this up on the router- how do I give a layer 3 interconnect IP address to the switch interface port 23. The router is out with my control but the config for this is
conf t
interface fastEthernet0/1
ip address 10.xxx.xxx.xxx 255.xxx.xxx.xxx
speed 100
duplex full
no shut
router bgp 65000
network 10.xxx.xxx.xxx mask 255.xxx.xxx.xxx
0
 

Author Comment

by:chriswilson265
ID: 33454299
Hi All, done some digging on the web and vendors like HP, Foundry ... "have a Vlan interface basis for the purpose of routing, unlike Cisco when you turn on a Switch port to a L3 router interface with no switchport command"
If this is the case then would the config that ikalmer suggested work and what would I have to get done on the cisco router side?
Thanks for your time.
chris
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 33454441
Hi,

you not able to create L3 interface for special port, only VLAN iterface on HP
0
 

Author Comment

by:chriswilson265
ID: 33454703
Hi ikalmer, so if I setup up the vlan as you suggested on the switch ....

ip routing
vlan 1
 ip add x.x.x.x x.x.x..x
vlan 2
 untagged 23
 ip address 10.xx.xxx.xxx 255.xxx.xxx.xxx

ip route 10.xx.xx.x 255.xxx.xxx.xxx.x 10.xxx.xxx.xxx

then get the guys that look after the cisco router to setup the vlan there end. Would that work??
0
 
LVL 17

Accepted Solution

by:
jburgaard earned 1000 total points
ID: 33455765
Your  vlan 2 comes untagged out on port 23, so no new needs for that matter in Cisco end.

On the other hand if you plan vlan1 ip address to be in an other range like fx 172.16.x.x or 192.168.x.x the cisco would need to have a static route to vlan1-network via ip address 10.xx.xxx.xxx 255.xxx.xxx.xxx (=IP of vlan2)

HTH
 
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 34399231
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0

Featured Post

Create the perfect environment for any meeting

You might have a modern environment with all sorts of high-tech equipment, but what makes it worthwhile is how you seamlessly bring together the presentation with audio, video and lighting. The ATEN Control System provides integrated control and system automation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question