Problem with netdom when transferring fsmo roles


I am trying to change our current windows 2k3 server over to 2008 R2, hardware is being replaced at the same time. We have one server for this domain and once the change over is complete I will remove the 2k3 server and have a single 2008 R2 server.

I have got as far as adding the 2008 server to the domain and started to transfer fsmo roles across.

Before transferring any roles I ran "netdom query fsmo" on the new server and all fsmo roles were shown as running on the original server netdom 1I have transferred RID, PDC and Infrastructure roles and everything appeared to be successful, however when I now run exactly the same command I get the failure message "The parameter is incorrect"  netdom 2

When I check the operations masters in AD users & computers they are shown as being on the new server.
 infrastructure PDC RID

Can anyone offer any advice on why netdom is not showing me all the roles, making no mention of the new server and how to resolve this?
Thanks in advance.  
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


Seems like "normal" behavior... :o)

Check here :

This part is the one that reflects your situation :

Using a command-line interface

In the following command, you can leave out the /Domain  option to query the domain you are currently logged on.

> netdom query fsmo /Domain:

For some reason, this command returns a "The parameter is incorrect" error on Windows Server 2003. Until that is resolved, you can use the dsquery server command shown here, where  can be schema, name, infr, pdc, or rid:

> dsquery server -hasfsmo

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Krzysztof PytkoSenior Active Directory EngineerCommented:
Move also Schema Master and Domain Naming Master from W2K3 to W2K8

Here, you can find how to do that
QEMSAuthor Commented:
Thanks very much for both of your responses, sorry about the delay responding but we have new fibre being connected through the site today as well.

I just wanted to query this before continuing with transferring the remaining two roles.
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

QEMSAuthor Commented:
I have now successfully transferred the remaining roles and used the script from the O'Reilly link which confirms the roles are running on the new server.

The command "dsquery server -hasfsmo <role>" returns an error code regardless of whether I use schema, name, infr, pdc, or rid as the role.

Is there a resolution to the command "netdom query fsmo" not working? Or is this something that will require an update from MS?
If you run the command on the 2008 server, does it yield the same result ?
QEMSAuthor Commented:
I was always running "netdom query fsmo" on the 2008 (R2) server - that result has stayed the same.

Ha ve you confirmed that your new server is actually holding the schema master role using the GUI ?
QEMSAuthor Commented:
The GUI shows it correctly and the script that is available on the O'Reilly page shows that the roles are on the 2008 server.

I haven't finished moving all the shares and data across yet, is it possible this will resolve itself once i have completed that and removed the 2003 server?
Yes, most likely.
QEMSAuthor Commented:
I had to resolve a DNS issue and then this command started working again.

Thanks again for the help.

I'm experiencing exactly the same behaviour as you describe. You are talking about resolving a DNS issue. Could you elaborate on that please ? Maybe thats my problem too.

Thx in advance
Ok !! solved.

I went on looking for the DNS-issue and I discovered the Server2003 had 2 external DNS-servers in its IP-config. Server2008 had as first DNS-server the server2003 and as second DNS-server server2008. I changed both servers' interfaces as follows :
first DNS-server : itself (Server2008 on the server2008 and ...)
second DNS-server : the other one (Server2003 on the server2008 and ...)

After changing that I guess I just had to wait. Because while looking for more answers on the internet, all of a sudden I got no more errors and the FSMO roles listed up perfectly to the new server.

Thx for getting me in the right direction.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.