Unable to access HTTP with IE but can with Firefox

I recently did a windows update which included an upgrade from IE 7 to IE 8. Since then, I've been unable to access secure websites with IE, Chrome, or Safari.. but have no problems with Firefox. Everything seems to be working OK on my computer. HTTP is fine, but not HTTPS. I've done everything I can think of, including:

1) Trying to do a system restore to a point before the update. Unable to do this. I keep getting a message, "Cannot restore to this point. No changes have been made to your computer."

2) Reinstalling and resetting IE8 (including all personal settings)

3) Made sure that SSL 2.0 and 3.0 are checked in internet security settings. I also turned off Windows Firewall. I know it's not a router firewall issue as I have other computers on the same network that have no problems getting to https via IE.

4) I usually use ESET NOD32 for antivirus, but just to be sure, I downloaded Kapersky and did a deep scan for viruses and root kit problems. Scan came up clean, so now I have 2 virus programs that don't see anything amiss.

5) Tried to do a sfc /scannow (can't complete this because it keeps asking me for an install CD and won't recognize the recovery files on the partition of my HP hard drive.. and I have no physical install disk).

6) Applied Windows Fix-it 50191

 Currently on Windows XP Media Center 2005, SP3. I use some banking and financial programs that are dependent on IE, otherwise I could do what I needed with Firefox. Thanks for any help!
RockytopAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Wayne BarronConnect With a Mentor Author, Web DeveloperCommented:
View this please

Cipher strength appears as 0-bit in Internet Explorer
http://support.microsoft.com/kb/261328

See if this will correct your issue.
Carrzkiss
0
 
TheMakCommented:
1. Click Start, and then click Run.

2. In the Open box, type one of the following
commands, and then click OK (copy and paste is your
best friend):

regsvr32 softpub.dll
regsvr32 wintrust.dll
regsvr32 initpki.dll
regsvr32 dssenh.dll
regsvr32 rsaenh.dll
regsvr32 gpkcsp.dll
regsvr32 sccbase.dll
regsvr32 slbcsp.dll
regsvr32 cryptdlg.dll

4. Click OK when you receive the message that says
DllRegisterServer in FileName succeeded.

5. Repeat for each command line listed above

OR

Internet Explorer Cannot Connect to Secure Web Sites

http://www.bleepingcomputer.com/forums/topic41067.html

OR

http://www.duxcw.com/faq/win/xp/secure.htm
0
 
mehhercCommented:
Have you checked the proxy setting within IE under the connections then LAN settings? Sometimes clicking all those reset buttons do not reset the proxy config. Also, disable all add-ins. Those reset buttons should do that, but just verify that it was done. As a last resort, check the hosts file in C:\Windows\System32\drivers\etc. The file should only contain "127.0.0.1       localhost". Everything else should be remed out. To rem it out, put a # and a space or two on each line. If you change anything, make sure you save to the exact same place and make sure it has no extension. After that, you would need to restart the pc.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
RockytopAuthor Commented:
I registered the dlls. Still not solved. However.. when I went to Help, About Internet Explorer, It shows Cipher Strength 0-bits, Update versions 0.  There is no Internet High Encrytion Download for IE 8 since it's already supposed to have it... thanks
0
 
kaksterCommented:
is it every https sites or is it only intranet-sites where you use integrated security
0
 
zsaurabhCommented:
Uninstall and Reinstall IE 8--- Only 1 solution
0
 
RockytopAuthor Commented:
it's EVERY https: site...

I've already done the ie8 re-install... no joy. :(

There is no proxy set.  Host file verified with nothing but the 127.0.0.1

Thanks for all the input... just nothing worked so far.
0
 
zsaurabhCommented:
Revert back IE7
0
 
Wayne BarronAuthor, Web DeveloperCommented:
My post was for IE6.
Do not think it will work with IE8.

Must be something similar to the issue, as it seems to be the same.
Just not sure if that are the same files, will have to test and check.
0
 
Wayne BarronAuthor, Web DeveloperCommented:
Try this (IE8 this time, but not the same as above, this is for no https access)
http://support.microsoft.com/kb/968089

Carrzkiss
0
 
flubbsterCommented:
Please see if there is an SSL Configuration Settings entry in group policy:

Open your group policy editor by entering gpedit.msc at a start>run command.
Choose Computer Configuration | Administrative Templates | Network | SSL Configuration Settings
0
 
RockytopAuthor Commented:
I had already followed all of the things in kb/968089.

In Group policy under administrative templates, I only have Windows Components. No SSL Config settings.

In IE 8, when I look at Network diagnostics, I have the following Messages in the "red" section:

warn HTTPS: Error 126 connecting to www.microsoft.com: The specified module could not be found.  
warn HTTPS: Error 126 connecting to www.passport.net: The specified module could not be found.  
info HTTP: Successfully connected to www.microsoft.com.
info FTP (Passive): Successfully connected to ftp.microsoft.com.
error Could not make an HTTPS connection.
info Redirecting user to support call

Everything else is "in the green"

0
 
TheMakCommented:
Last thing download and install ProcMon software from Microsoft and try to capture the error.
 
Regards,
0
 
RockytopAuthor Commented:
Thanks all... I have the solution now... carrzkiss was on the right track with the http://support.microsoft.com/kb/261328 link.   I found that my windows/system32 directory was completely devoid of the schannel.dll file.. I extracted this file from my HP's install backup drive and placed it in the system32 directory, and then rebooted. Now, IE8 shows 128 bit encryption and I'm back online with all the https: sites... Thanks to EVERYONE for your suggestions. A lot of great minds here.
0
 
RockytopAuthor Commented:
carrzkiss put me on the right trail for the final solution that I hammered out myself.. But couldn't have done it without his help.. THANKS!
0
 
TheMakCommented:
Great... I was confused why carrzkiss link did not solve your problem........ He was on the right track but you got confused I think...
0
 
Wayne BarronAuthor, Web DeveloperCommented:
Glad I could help.
Good Luck.

Carrzkiss
0
 
miesupportCommented:
I am encountering the same problem (IE shows "Page cannot be displayed" for all https webpages, but Fifrefox is fine). Our problem seems to be a different root cause. Some background info, the computer was infected, and we cleaned it up using various anti-malware/anti-virus tools.

I tried upgrading IE8 to IE9 (Vista machine). Today we noticed that when viewing the list of certificates in IE (e.g. Trusted Root Certification Authorities), it is completely blank. But certificates seem intact in Certificate mmc snap-in (certmgr.msc).

Any ideas on what could be the problem? I've been stumped thus far and any idea, big or small would be greatly appreciated.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.