Solved

Second SMTP service or Port

Posted on 2010-08-17
30
571 Views
Last Modified: 2012-05-10
I have setup a new echange 2010 server and everything is working fine except some emails that i had setup to go to my old exchange server on port 2525.

How do I create a seond smpt listen port in Exchange 2010 and server 2008 so these come through.


Thanks
0
Comment
Question by:stacystyles
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 14
  • 10
  • 4
  • +1
30 Comments
 
LVL 32

Expert Comment

by:endital1097
ID: 33453617
you need to create an additional receive connector
http://technet.microsoft.com/en-us/library/bb125159.aspx
0
 
LVL 8

Expert Comment

by:SGrossmann
ID: 33453631
Open EMC goto Server Configuration -> Server -> ReciveConnectors and add a new connector that listens on port 2525 (tab network)
0
 
LVL 8

Expert Comment

by:SGrossmann
ID: 33453635
addionaly you need to make sure that you open the port in windows firewall if your firewall is running.
0
Instantly Create Instructional Tutorials

Contextual Guidance at the moment of need helps your employees adopt to new software or processes instantly. Boost knowledge retention and employee engagement step-by-step with one easy solution.

 

Author Comment

by:stacystyles
ID: 33453801
Ok  I have gone in and done this but I cannot telnet to this port.  I made it an Internet port because it will be emails from the outside world.  
0
 
LVL 8

Expert Comment

by:SGrossmann
ID: 33453812
did you open the port in the firewall?
0
 
LVL 17

Expert Comment

by:Suraj
ID: 33453939
i would like to know what exactly do you want to achieve.
you said old servre? what is it? and why port 2525. Thanks

Suraj
0
 

Author Comment

by:stacystyles
ID: 33454172
Here is what I am trying to do.

I have my exchange 2010 server and an Exchange 2003 server.  All mail used to go to teh Exchange 2003 server but now that I have implemented my Exchange 2010 server all mail goes through it and delivers to my Exchange 2003 server.  Now for some reason I cannot get emails the are sent to us from our remote systems sending to mail.XXXX.com:2525
0
 

Author Comment

by:stacystyles
ID: 33454209
Here is the respnse I am getting from my send program.   mail.xxxx.com:2525 is failing
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33454212
do you have a routing group connector that connects 2003 with 2010
get-routinggroupconnector
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33454216
did you select the anonymous permission group
0
 
LVL 17

Expert Comment

by:Suraj
ID: 33454307
You need to have a routing group connector between Ex2010 and exchange 2003. No send connectors - smarthost to any port between them !
you can figure that out from exch 2003 ESM !
Just want to know .. why 2525?
0
 

Author Comment

by:stacystyles
ID: 33454402
Everyone here is the deal.

I am able to receive emails with no issues when emails are sent to my company using hotmail etc.  They route to my exchange 2010 server and then get forwarded to me Exchange 2003 server.  The issue is that I have application servers at hospitals that will not allow my bmail program to send out on port 25.  Instead I have them setup to send to my server using port 2525. This all worked fine on Exhange 2003 as I had my server setup to rceive emails on port 2525 as I had a spam software product using port 25.

Now emails are being routed to my exchange 2010 server and smpt service is setup on port 25 like the default.  All mail that is destined to come to me on port 2525 is not getting to my new exchange server.  I have setup a new receive connector on port 2525 but it is not working.  Do I have to do something with the SMTP service as well?
0
 
LVL 8

Expert Comment

by:SGrossmann
ID: 33454423
coming back to my question above, did you check the firewall of the exchange 2010 server?normaly you don't need to do any further changes to be able to connect to the port with telnet.they only thing you need to do afterwards is to set the permissions for anoymous as mentioned above.
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33454425
can you run the cmdlet below against the connector you created
get-receiveconnector Application | fl

we can check the settings for the connector for issues
0
 

Author Comment

by:stacystyles
ID: 33454477
I have opened the port and permissions are set to anoymous.
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33454478
the settings you need to check are
Bindings = {0.0.0.0:2525}
PermissionGroups = AnonymouseUsers,Custom
RemoteIPRanges = {10.0.0.0/24}

the RemoteIPRanges should be the subnets/IP addresses that will use this connector

0
 

Author Comment

by:stacystyles
ID: 33454485
Endital where should I run that script from?
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33454501
from the exchange management shell
0
 

Author Comment

by:stacystyles
ID: 33454571
I ran the script and it errrored out.
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33454598
first run the following to list out your receive connectors
get-receiveconnector

the run it with the connector name you created and add the | fl
example: get-receiveconnector server\anonymous | fl
0
 

Author Comment

by:stacystyles
ID: 33454626
SOme pics of the connector
Exchange1.jpg
Exchange2.jpg
0
 

Author Comment

by:stacystyles
ID: 33454650
Here are the rest of the pics
excnage-3.jpg
exhange4.jpg
exchange5.jpg
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33454698
on the authentication tab remove all but TLS
on the permissions group tab remove all but Anonymous

0
 

Author Comment

by:stacystyles
ID: 33454704
Here are two pics from the print out
printout1.jpg
printout2.jpg
0
 

Author Comment

by:stacystyles
ID: 33454722
Changes made still no luck.  Do I have to restart services?
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33454762
can you temporarily disable the firewall on this exchange server to ensure that it is not the issue? then attempt to telnet from your workstation on port 2525
0
 

Author Comment

by:stacystyles
ID: 33454801
Firewall is always off and I can telnet locally to 10.220.8.188 2525
0
 

Author Comment

by:stacystyles
ID: 33454827
but from any other box I cannot
0
 
LVL 32

Accepted Solution

by:
endital1097 earned 500 total points
ID: 33454832
that means the connector is working and something in front of your exchange server is blocking the port
0
 

Author Comment

by:stacystyles
ID: 33454934
Looks like someone turned the firwall on as well.   Thank you for all your help.
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Find out what you should include to make the best professional email signature for your organization.
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Suggested Courses
Course of the Month6 days, 5 hours left to enroll

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question