SyncBack file time stamp change

I use SyncBack to backup various directories from my server to external USB drives, some are whole backups to store in a different location, some are partial backups when I need to take certain data with me travelling. This all works well, but I notice that there s usually a big chunk of files that have the time shifted by one hour, this means that SyncBack the re-copies them slowing down the process.

These files shouldn't have been edited or moved so I'm a bit mystified as to why the time change. It sometime means that backing up a couple of hundred files can take all night as there are thousands of 'changed files' to copy too.

I can get SyncBack to ignore file time changes of 1 hour 1 minute - that cures the problem, however that seems like a work around. I'd like to get to the bottom of why the times are changing.

Thanks

Mark Preston
Mark PrestonSystems EngineerAsked:
Who is Participating?
 
Gary CaseConnect With a Mentor RetiredCommented:
I wouldn't have said it was there if it wasn't :-)       Although I use SyncBack SE (a very nice product that's worth the few $$ it costs);   I installed the freeware version on another system to confirm whether or not you had the option available -- and posted the details on how to set the option based on that.      Clearly you simply have an older version that doesn't have the option -- so just download the latest freeware version (v3.2.21.0) and you'll be fine.    



SyncBack-DST-Option.JPG
0
 
John HurstBusiness Consultant (Owner)Commented:
Do you have a different time setting on your server than correct? I have been using SyncBack Pro for a long time now, and my times are correct. It looks like one of the machines has a daylight saving setting issue. ... Thinkpads_User
0
 
zimbixCommented:
I use SyncBack, and it's really good!
In the pro version most likely, you should be able to change the comparison method to checksum/file contents, but I'm not too sure.
Try: with each profile > Modify > Compare Options > Use slower but more reliable method
or as a last resort use an external comparison program: Preferences > Comparison Programs
I think you'd probably get the best feedback though from posting on the 2BrightSparks support page:
http://www.2brightsparks.com/help/index.php
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Mark PrestonSystems EngineerAuthor Commented:
I'll check DST tonight.

I use the free version of SyncBack so don't think I will have all those options.
0
 
John HurstBusiness Consultant (Owner)Commented:
SyncBack Pro is not expensive, so you might wish to consider upgrading.  .... Thinkpads_User
0
 
Gary CaseRetiredCommented:
First, this is clearly not a "Syncback" issue -- as you've noted you can easily work around it.

With Syncback, I wouldn't change the "ignore" time to 1 hr + 1 min -- leave it however you current have it (typically 1 or 2 minutes is a good choice to protect against slight variations in your PC's clocks).   Just check the "Ignore file date & time changes that are because of Daylight Savings Time (DST) changes" box in the comparison options and it'll work as you want with files that are an hour apart (within the variance setting you've selected) ... but will catch "real" changes with time differences less than that.

As for what's causing the issue -- I suspect (as suggested above), that you have a PC with an incorrect DST setting.    Check that first.    If that's not it, you may have a program or utility that's altering the time stamps incorrectly.    Are all of the files with the altered time stamps the same kind of files?    .... or have they been accessed/used by the same utility in-between backups?
0
 
Mark PrestonSystems EngineerAuthor Commented:
I have checked all the PCs and they all appear to be on the same DST settings. I have all the clocks to sync to Internet time, but all of them said 'error syncing time' but were within a minute or so of each other. My version of SynchBack (the free one) doesn't seem to have the "Ignore file date & time changes that are because of Daylight Savings Time (DST) changes". Do I have to uprade to Pro to get that?
0
 
John HurstBusiness Consultant (Owner)Commented:
I think that would be the best thing. I do not see any way this is a SyncBack issue, but at least the Pro version gives you more options. ... Thinkpads_User
0
 
Gary CaseRetiredCommented:
The freeware version of Syncback has that option.     It's on the "Compare Options" tab.     Select a profile;  click Modify;  click Advanced; then click on Expert -- you'll then see a "Compare Options" tab that has that option.
0
 
Mark PrestonSystems EngineerAuthor Commented:
I'll try that tonight, thanks
0
 
Mark PrestonSystems EngineerAuthor Commented:
There is no mention of DST here....
Image2.jpg
0
 
zimbixCommented:
In that screen, try ticking the top option
0
 
Mark PrestonSystems EngineerAuthor Commented:
Use slower but more reliable method of file change detection?
0
 
zimbixCommented:
yeah
0
 
Mark PrestonSystems EngineerAuthor Commented:
Ahh... I probably didn't download it because I thought that it would immediately want to charge me! I'll look to upgrade and post back!

Thanks
0
 
Mark PrestonSystems EngineerAuthor Commented:
That worked a treat. Thanks!!
0
All Courses

From novice to tech pro — start learning today.