?
Solved

Subscription issues in SQL RS 2008

Posted on 2010-08-17
1
Medium Priority
?
514 Views
Last Modified: 2012-05-10
Hi,
I have set up a user in SSRS 2008 with Browser access (May view folders, reports and subscribe to reports).  He has a copy of a report in his user folder that is linked back to the main report. Right now he can't subscribe to email subscriptions.  When he goes to the subscription screen, his name is displayed as the active directory listing and is greyed out so he cannot enter his email address in the TO: field( it auto fills with the Active Directory name and it is greyed out so it cannot be changed).  Does he need to have access to the main report(not the linked report) for this to work?

Thanks,
R
0
Comment
Question by:Rhonda Carroll
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 14

Accepted Solution

by:
wolfman007 earned 2000 total points
ID: 33487320
By default Reporting Services put the Windows Domain account in the to field, you need to change the setting in Reporting Services to allow the user to insert his email address. You do this in your RSReportServer.config file.

Remember to take a backup of your RSReportServer.config before making any changes to it.

See below.

Configuration Options for Setting the To: Field in a Message

User-defined subscriptions that are created according to the permissions granted by the Manage individual subscriptions task contain a pre-set user name that is based on the domain user account. When the user creates the subscription, the recipient name in the To: field is self-addressed using the domain user account of the person creating the subscription.

If you are using an SMTP server or forwarder that uses e-mail accounts that are different from the domain user account, the report delivery will fail when the SMTP server tries to deliver the report to that user.

To workaround this issue, you can modify configuration settings that allow users to enter a name in the To: field:

1) Open RSReportServer.config with a text editor.
2) Set SendEmailToUserAlias to False.
3) Set DefaultHostName to the Domain Name System (DNS) name or IP address of the SMTP server or forwarder.
4) Save the file.

from the following website

Configuring a Report Server for E-Mail Delivery
http://msdn.microsoft.com/en-us/library/ms159155(v=SQL.100).aspx
0

Featured Post

Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SQL Server engine let you use a Windows account or a SQL Server account to connect to a SQL Server instance. This can be configured immediatly during the SQL Server installation or after in the Server Authentication section in the Server properties …
Ever needed a SQL 2008 Database replicated/mirrored/log shipped on another server but you can't take the downtime inflicted by initial snapshot or disconnect while T-logs are restored or mirror applied? You can use SQL Server Initialize from Backup…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question