Trixbox Not Picking Up Public IP

I've played around with Trixbox before and haven't ever had any issues picking up the Public IP. However, on this installation, everything is working except for the Trix CE 2.8 picking up the Public IP. We are testing a couple of things and for the sake of simplicity, were throwing it on a VM box. In the process of troubleshooting, I've even tried adding a 2nd NIC but that didn't work (with a public IP). So, to the genius Linux people - PLEASE HELP! :)

Details - Were behind ISA 2006. Trying to run IAX2. Opened UPD 5060 both ways. Everything else is working fine. ISA handles NAT as well as is the Gateway. Checked all NIC settings multiple times.
dsmjeffAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DrDamnitCommented:
What do you mean picking up the public IP?

Are you talking about a 1:1 NAT? You said you're behind ISA, which means unless you're running 1:1 NAT (which may be problematic in and of itself) you're not on a public IP.

Please clarify.
0
dsmjeffAuthor Commented:
The internal subnet is behind ISA which provides NAT.

We have a pool of public IP's x.x.x.161/174 that we use. The public interface on the ISA that all traffic routes out of is x.x.x.162. When I check the status of the Trixbox on the Web GUI, it shows the LAN IP, but the "PUBLIC" IP is blank.

What other information would you need? The setup of our network is pretty straightforward. I know ISA most likely isn't the concern because our other (original) Trix install ran on a box behind ISA as well. However, this one is VM, so I'm not sure if it is the install or the VM causing fits.
0
DrDamnitCommented:
I don't use Trixbox. I do everything with pure Asterisk. So, I am not too familiar with the GUI.

Can't you just set the Public IP address?

I am assuming your VM has two network adapters, right?

Can you log into the shell, and post the output of ifconfig?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

dsmjeffAuthor Commented:
I'm not really that fluent in Linux. I can dabble, but that's about it. I can add several interfaces, but w/ the GUI of Trix I can only program the IP and DNS, so it really would allow me to setup the rest of the public stuff (GW, DNS, etc).

How do I accomplish this in the shell?
0
DrDamnitCommented:
1. Using this guide, make sure you have Trixbox setup so that you can SSH into the box: http://www.sureteq.com/asterisk/trixboxv1.2.htm#5.0_-_General_Trixbox_Setup/Security_

You may need to start at the top of the document and work you way down to that section if there are parts / pieces of it that don't work.

2. Log into the box using putty (http://www.chiark.greenend.org.uk/~sgtatham/putty/) and the admin username and password.

Then type ifconfig, and post the results.
0
dsmjeffAuthor Commented:

[trixbox ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:22:22:D9
          inet addr:172.16.1.29  Bcast:172.16.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe22:22d9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3005 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1886 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2808558 (2.6 MiB)  TX bytes:332814 (325.0 KiB)
          Interrupt:59 Base address:0x2000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:345 errors:0 dropped:0 overruns:0 frame:0
          TX packets:345 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:28317 (27.6 KiB)  TX bytes:28317 (27.6 KiB)

[trixbox ~]#


0
DrDamnitCommented:
You only have one virtual adapter in the VM. You need to add a second.
0
dsmjeffAuthor Commented:
But our typical installs only have one adapter, so I'm confused. Typically we have a physical machine with one NIC. The NIC has a Static IP that we configure for the LAN and the TB install automatically picks up a WAN IP via DHCP. In this case, it is not.
0
DrDamnitCommented:
That makes no sense. WAN IP's do not come from DHCP unless you have a provider who does that. And even then, they are not going to issue you a public IP address. It has to be configured as a static unless you have a device that issues those IPs.

What you're talking about is multiple IP addresses on a single interface, which is common, but not automatic.

Add a second adapter, or setup the secondary IP address.

http://www.cyberciti.biz/faq/linux-creating-or-adding-new-network-alias-to-a-network-card-nic/#rhel

I'm not saying that this could have NEVER happened. I am just saying in 10 years of doing this, dealing with every type of connection from MetroE to Fiber, to T1, to E1, to cable, to DSL, to ISDN... I have NEVER seen public ip's issued via DHCP.
0
dsmjeffAuthor Commented:
I should have been clearer - behind the ISA which translates the private to the public, I haven't had to have multiple NICs. As a test, I setup another rule in ISA to access SSH from the Public to the LAN on the Static IP that we have setup. The results were I was able to access SSH direct to the Trixbox from the outside Internet. However, the trunk is still not registering with our provider who has checked our configs and verified.


0
dsmjeffAuthor Commented:
I'll try it - but if I set up the "WAN" on TB, how do I tell TB to use that for publishing communications on the Web?

Thanks
0
DrDamnitCommented:
It just "knows". When the public IP is assigned to the virtual adapter, the routes will forward traffic properly.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dsmjeffAuthor Commented:
The Trixbox is now communicating on the trunk. The GUI still doesn't show the Public IP, but it is working. I left just the one adapter registered.

Thanks for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.