Solved

Configuring a Cisco 2811 with one HWIC-4ESW and Multiple DSL connections

Posted on 2010-08-17
11
1,053 Views
Last Modified: 2013-12-14
I have a 2811 router with one HWIC-4ESW, I want to run each dsl router on each of the HWIC interfaces.  All the DSL routers have the "Dot one" (192.168.1.1, 192.168.2.1, 192.168.3.1, 192.168.4.1) addresses,
the interfaces are programmed as such: (FA0/3/0 192.168.1.2,  FA0/3/1 192.168.2.2, FA0/3/2 192.168.3.2, FA0/3/3 192.168.4.2.    I am connecting the internal LAN to the FA0/0 10.10.1.1 with a dhcp pool of 10.10.1.30-100 with the 10.10.1.xx (30 and below excluded)

I have configured the interfaces into VLANS, Vlan1 is default for FA0/0, Vlan 2 FA0/3/0 VLAN 3  FA0/3/1, Vlan 4 FA0/3/2, and lastly VLAN 5 FA0/3/3
Can I load balance the DSL connections over the VLANs (VLAN 2-5)?  if so how?
Can I just program static routes from the FA0/0 to the seperate 192.168.x.x addresses with the priority? Max users on the internal 10.10.X.X is 60 users period. scalability is not needed, load balancing to optimize the connections is.
could you include a detailed description and how you would program this?
Thanks!
0
Comment
Question by:gb428
  • 5
  • 4
11 Comments
 
LVL 4

Expert Comment

by:Tory W
ID: 33470229
I guess since no one has answered this yet I will assist you once again.

So, since these are DSLs not T1s you can still use PVST or NAT.

I will post the NAT config because that will allow you to set it and forget it.  It is a bit more complex than multilink but should be no problem. (I will post a few generic IPs rather than what you have because I understand what you are doing just not exactly what you have for an IP scheme) (if you have concerns on what IPs go where we can line that out)
Here is what I used as a basis for this config.

so,
not an easy task but worth it in the end.

#####These are your ports going out to your ISP#####
interface FastEthernet0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
no ip address
pppoe enable
 no cdp enable



######This is your interfaces facing your network users######
interface Vlan1
 description LAN Interface
 ip address 192.168.X.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452



#####Assign IP nat outside on Dialer 0#####
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss



######Telling everything to route out Dialer 0 Profile#####
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123

 
#####Using NAT overload to allow route maps######
ip nat inside source route-map fixed-nat interface Dialer0 overload
ip nat inside source route-map dhcp-nat interface FastEthernet0 overload
 

#####here is where you define your IP range for users#######
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!

!--- Define ACLs for traffic that are NATed to
!--- the ISP connections.


#####This pairs NAT access lists with NAT outside######
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0


####NOTE: you will need an IOS on your Router that can handle these configs.  (you may need to update your IOS)





0
 

Author Comment

by:gb428
ID: 33472286
Ok,
I see the solution but I am a bit confused..
1, why set the command pppox dialer and dialer0 or ppoe for that matter.. I have 4 DSL routers, they are external so the interfaces I will use to connect the 2811 to the dsl's is the fast ethernet connection on the DSL routers themselves. Each Dsl router has a phone connection for the dsl, they also have an ethernet interface for connecting to the LAN.
This is why I was asking if there was a way to load balance the VLANS I created to attah my internal 10.10.X.X network to the HWIC assigned VLANS.. I was thinking that if I assigned four static routes from the 10.10.X.X to the HWIC interfaces and then assign a value that it would work.. Does this sound right?
Thanks again
0
 
LVL 4

Accepted Solution

by:
Tory W earned 500 total points
ID: 33478456
Ahh, I understand now.
I was always wondering why you said "routers" but only mentioned you had 1 router (2811).

So esentially you have 5 routers- 4 DSL and 1 2811.


You can use static routes and it will load balance if the links are considered the same administrative distance and cost. (all static routes have the same AD)

So to be clear your FA0/3/0 -3 are each going to your DSL routers and the FA0/0 is going to your interior LAN (VLAN 1 only?)



Here is the documentation on this:
Load Balance

The conifgs you will need are as such:

####routes pointing to ISP####
ip route 0.0.0.0 0.0.0.0 FastEthernet0/3/0
 ip route 0.0.0.0 0.0.0.0 FastEthernet0/3/1
ip route 0.0.0.0 0.0.0.0 FastEthernet0/3/2
 ip route 0.0.0.0 0.0.0.0 FastEthernet0/3/3

####route back to your 10.10.1.0 network ####
####assuming your FA0/0 has and ip address of 10.10.10.2)####
ip route 10.10.1.0 255.255.255.0 10.10.10.2



Sorry such a long issue for such a small config.  I guess I thought you had a tougher problem than it was.
0
 

Author Comment

by:gb428
ID: 33479455
Thanks,

I kinda thought this could be done like you said,,,but I didi not want to jump in and just program blindly if you will..

Thanks again..
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:gb428
ID: 33479469
BTW, last question, this I assume is running RIP?

Thanks again....
0
 
LVL 4

Expert Comment

by:Tory W
ID: 33488639
The static routes should be all you need.  
Just as long as you are able to get from your wireless routers out to the internet.  

I would have to check my wireless router at home, but the ISP should handle that portion of the config.  


0
 

Author Comment

by:gb428
ID: 33495125
Tory,
with this statement:
####route back to your 10.10.1.0 network ####
####assuming your FA0/0 has and ip address of 10.10.10.2)####
ip route 10.10.1.0 255.255.255.0 10.10.10.2

Shouldn't this be:
####route back to your 10.10.1.0 network ####
####assuming your FA0/0 has and ip address of 10.10.10.2)####
ip route 192.168.0.0 255.255.0.0 10.10.1.1

After using your solution, i received an error: invalid next hop address, its this router..
the FA0/0 address is 10.10.1.1

Regards
Glenn B
0
 
LVL 4

Expert Comment

by:Tory W
ID: 33501785
this should be advertising your inside network
ip route convention is as such:
ip route (network you are advertising) (subnet mask of network) (next hop ip address)


so you are telling incoming packets where their next hop is if they are trying to get to your 10.10.1.0 network.

so use ip address 10.10.1.0 255.255.255.0 10.10.1.1

This tells incoming packets that have a destination of your 10.10.1.0 network that their next hop is 10.10.1.1 (or simply go out the fa0/0 port) (the point is that the last ip address in the statement needs to be the ip of your fa0/0 port)

192.168.0.0 may cause you problems because you are telling your router that the destination for the 192.168.0.0 network is out the fa0/0 port
0
 

Author Comment

by:gb428
ID: 33556180
Thanks toryw...
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now