Access Based Enumeration (ABE) Wont Work

Hi All,

I'm trying to implement access based enumeration on our server (2008) to make things a little simpler for our users

Basically every user has a shared folder and there is also a public share that is available to all users

i need to get it to the point where each user sees only 2 shares "Their own" and the "public volume"

in "Shares and Storage management" ive enabled ABE on every share (most were enabled by default)

ive also set the "share" permissions but not the "ntfs" permissions (no user will ever access the server from console)

but every user can still see everybodys share, even though they cannot access them

Have i missed something????
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

I'm not sure about 2008, but under 2003 you had to issue this command every time you made a change to a drive or share.  I have this in a batch file on our file server cluster because it has to run every time we switch nodes:

abecmd /enable /server . /all
ChrissalterAuthor Commented:
its not recognising the command

"'abecmd' is not recognized as an internal or external command"
ChrissalterAuthor Commented:
I'm either really missing something or ABE doesnt work at all

just tried it on a win 2k3 server and it doesnt work on that either, can still see every shared folder

can anybody actually verify that "ABE" can work??? i'm losing faith.....
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

You'll never get this to work with *share* permissions; how could you? If access is controlled by share permissions only, and the user has to have permissions to connect to the share to start with, how could there be folders to which he does NOT have permissions?
Set *share* permissions to Everyone:Full (there is no security gain in using both share and NTFS permissions), and control access with NTFS.
Share permissions are a leftover from OSs and file systems without access control, to provide a bare minimum of access control. Compare the access options you get in share permissions to those available in NTFS.
For windows 2003 I can verify it does work, but it is not included with the OS by default.  You have to download it here:

For 2008 it looks like it is included and activated by default, but it doesn't work with DFS without configuration.  If you are using DFS take a look at this article:
oBdA is right.  ABE filters viewing of folders within shares based on NTFS permissions, not the shares themselves.  Everyone will still see all root shares even if they can't access them unless they are hidden shares.  Then no one will see them by browsing.
ChrissalterAuthor Commented:
Thankyou, will give it a shot and report back
ChrissalterAuthor Commented:
Have tried setting the security permissions to the point where the user is the only account with access and also the owner

but its still showing up in the shared folder list

might sound a little clueless but just to elaborate "NTFS Permissions" are the ones on the tab labeled "Security"?
Just in case: you can NOT test ABE with an account that has Administrator permissions on the host server. ABE is not applied to Administrators ever.
That said: what exactly do you mean with "still showing up in shared folder list"?  ABE hides only the directory listings, NOT any shares seen through the network with "net view \\server" or Explorer or whatever.
If you want to hide the shares, you need to add a $ at the end of the share name (and connect accordingly to \\server\share$).

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ChrissalterAuthor Commented:
I was under the impression that abe made \\server\share invisible, should have done my homework before tinkering, thankyou for the help
Please note that hiding a share by adding a $ is NO SECURITY MEASURE. The "$" tells the CLIENT(!) software, not the server, to "please, if you feel like it," not show this share. The share itself will remain visible for all kinds of tools, it's just hidden in Explorer or "net view".
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.