Solved

stsadm error when exporting a discussion board

Posted on 2010-08-17
7
908 Views
Last Modified: 2012-05-10
I'm trying to move a discussion board from my DEV environment to PROD.

It is a large discussion which I had to raise the template size on. I was hoping to just save it as a template. But then there is this:  http://support.microsoft.com/kb/960969

So I am left with stsadm export/import but I am receiving an error.

here is my stsadmn command:
stsadm -o export -url http://devsp/groupname/ABCD/Lists/Archive%20Discussion/ -filename c:\ABCDArchDisc.bak

here is my error:
The URL provided is invalid. Only valid URLs that are site collections or sites are allowed to be exported using stsadm.exe.

???
0
Comment
Question by:sullisnyc44
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 10

Expert Comment

by:ImaCircularSaw
ID: 33456122
Is this a list you're trying to export?
0
 
LVL 10

Accepted Solution

by:
ImaCircularSaw earned 500 total points
ID: 33456212
If it is a list then STSADM does not support exporting lists or list items, only sites.  You can use the instructions in one of my previous answers to back up a list:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/MS-SharePoint/Q_26375990.html

Hope this helps!
0
 

Author Comment

by:sullisnyc44
ID: 33456786
its a discussion board.

I guess I will try it.

Thanks.
0
The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

 

Author Comment

by:sullisnyc44
ID: 33456805
does this need to be installed on my prod server too? Or can I run it all from dev to my production server?
0
 
LVL 10

Expert Comment

by:ImaCircularSaw
ID: 33458619
You'll need the extensions on both servers, if I remember rightly.
0
 

Author Comment

by:sullisnyc44
ID: 33501146
when I migrated the discussion board - the replies to the main topics look as though they were created in subfolders. will this copy those subfolders?
0
 

Author Comment

by:sullisnyc44
ID: 33501171
looks like it is copying everything I need. I will let you know how the import goes.

Thanks!

0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently came across an issue with a MOSS 2007 deployment where access into some sub-sites were denied, even for the MOSS farm administrators. A bit of background to the setup of this MOSS farm; this was a three server setup, consisting of a fr…
The vision: A MegaMenu for a SharePoint portal home page The mission: Make it easy to maintain. Allow rich content and sub headers as well as standard links. Factor in frequent changes without involving developers or a lengthy Dev/Test/Prod rel…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question