Solved

Windows 2008 MMC crashes when adding a Snap-In

Posted on 2010-08-17
16
5,342 Views
Last Modified: 2012-05-10
Windows Server 2008  SP2 - 32 bit

Every time I try to add in a Snap-In for MMC - specifically for Certificates - MMC Crashes.  I am trying to install this for the Thawte root upgrade.

https://search.thawte.com/support/ssl-digital-certificates/index?page=content&id=SO15084
0
Comment
Question by:smolinitek
  • 8
  • 7
16 Comments
 
LVL 5

Expert Comment

by:TechnicallyMaybe
ID: 33456453
From: http://www.petri.co.il/forums/showthread.php?t=10782
MMC startup crashes are normally related to leftover .tmp files on your system. Clear all .tmp files from the Temp directory and restart the MMC. If the MMC still crashes,

1. Shut down user applications on the system.

2. Log off the system.

3. Log back onto the system.

4. Search for for *.tmp files in the c:\temp directory (the directory to which the TEMP variable is pointing).

5. Delete the *.tmp files.

6. Restart MMC.

Problem: MMC does not work correctly. You may find that the MMC behaves strangely, or it may not work at all. Problems usually occur when the system running the ISM (and any MMC-based snap-ins) has less than 2 MB of available disk space.

Solution: To resolve the problem, free up disk space on the system.

For more information, see Microsoft Knowledge Base article Q184312.
0
 

Author Comment

by:smolinitek
ID: 33459041
I am running Server 2008.  I do not see a c:\temp folder.  I can do search and find all.*.tmp files.

There is more than 100GB of space available on my C: drive.  What is next - do I delete all of my *.tmp files on my entire c: drive?
0
 
LVL 59

Accepted Solution

by:
Darius Ghassem earned 500 total points
ID: 33459134
0
 

Author Comment

by:smolinitek
ID: 33459193
I don't have another machine to copy the registry from.   There has to be a fix out there.  This very strange and weird.
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 33459260
What is the exact error you are getting?
0
 

Author Comment

by:smolinitek
ID: 33459299
As soon as I add in the "certificates" or any other one snap-in and click OK the MMC crashes and says it has stopped working.  

Where would I find the error log for these to provide you more information?
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 33459310
Have you tried running sfc /scannow
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 33459316
Look in the Event viewer
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 

Author Comment

by:smolinitek
ID: 33459362
Faulting application mmc.exe, version 6.0.6002.18005, time stamp 0x49e01c0a, faulting module ntdll.dll, version 6.0.6002.18005, time stamp 0x49e03821, exception code 0xc0000374, fault offset 0x000afaf8, process id 0x1950, application start time 0x01cb3e50b9645fe0.

--------------------------------------------------------
Log Name:      Application
Source:        Application Error
Date:          8/17/2010 5:11:27 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      WIN-GCNZ1GHHZ05
Description:
Faulting application mmc.exe, version 6.0.6002.18005, time stamp 0x49e01c0a, faulting module ntdll.dll, version 6.0.6002.18005, time stamp 0x49e03821, exception code 0xc0000374, fault offset 0x000afaf8, process id 0x1950, application start time 0x01cb3e50b9645fe0.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2010-08-17T21:11:27.000Z" />
    <EventRecordID>194667</EventRecordID>
    <Channel>Application</Channel>
    <Computer>WIN-GCNZ1GHHZ05</Computer>
    <Security />
  </System>
  <EventData>
    <Data>mmc.exe</Data>
    <Data>6.0.6002.18005</Data>
    <Data>49e01c0a</Data>
    <Data>ntdll.dll</Data>
    <Data>6.0.6002.18005</Data>
    <Data>49e03821</Data>
    <Data>c0000374</Data>
    <Data>000afaf8</Data>
    <Data>1950</Data>
    <Data>01cb3e50b9645fe0</Data>
  </EventData>
</Event>
0
 

Author Comment

by:smolinitek
ID: 33459524
I tried running sfc /scannow - what is this suppose to do?  It run in the DOS window and just stops when it gets to 100%.
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 33459543
Run from the RUN line.

This fixes any corrupt Windows system files.

Remove any antivirus software as well.
0
 

Author Comment

by:smolinitek
ID: 33459663
I have run it and removed any anti-virus software.  Restarted.  Go back into the MMC and add in a Snap-In and it crashes again.  This is now just getting funny.  Wow this is driving me crazy.  Thank you guys for your help!!  
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 33459758
I am out of ideas this seems to be an issue with Windows 2008 server I have seen MMC crash on multiple snap-ins but those all have hotfixes for them I don't see a hotfix for yours.

I would suggest openning a case with MS.
0
 

Author Comment

by:smolinitek
ID: 33464282
I tried this solution but it won't let me delete the "SnapIns" folder.


Your Servers Registry to Microsoft Management Console is corrupted. Please try this:
a)    Find the Microsoft Management Console snap in Registry from a working Server. (If you dont have a other Server 2008 R2 create a virtual Server)
!IMPORTENT! : Snap-in must be installed there! if any snap-in is missing on the working machine, you will not be able to run that after!!! Please use a machine that has similar roles and features.
Snap-ins are in the following Registry path:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns
b)    Export SnapIns (as a .reg file) with its subkeys on your Server
 
c)    Backup your SnapIns on your problematic Server and delete the Registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns
d)    Export SnapIns to your problematic Server Registry
e)    Microsoft Management Console must work now !
0
 

Author Comment

by:smolinitek
ID: 33464313
Update.  After I tried to delete the "SnapIns" folder and it would not let me - I just imported the file I exported from another server.  It gave me an error saying "everything was not imported."  I went to MMC and everything works fine now.  It is a Christmas Miracle!!  Thank you guys for helping out.
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 33464326
Try booting in Safe Mode.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

To effectively work with Diskpart on a Server Core, it is necessary to write some small batch script's, because you can't execute diskpart in a remote powershell session. To get startet, place the Diskpart batch script's into a share on your loca…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…

939 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now