Solved

Cant activate Blackberry since upgrading to Bes Expres 5.02

Posted on 2010-08-17
6
1,832 Views
Last Modified: 2012-05-10
Hi there,

I upgraded our Blackberry Server Express to 5.02. Since the upgrade, one of the devices has stopped been able to send/receive email and i am no longer able to active devices over OTA or by cable. All the other devices are working fine.

The BES software runs on a 2003 R2 box with Exchange 2010 running on a 2008 box.

When i try and 'Resend service books for the device that is connected to your computer and that you are managing.; i get the error: The BlackBerry Administration Service was unable to activate the device that is connected to your computer. The BlackBerry Administration Service was unable to retrieve activation attributes from the device that is connected to your computer. Check to make sure that a device is connected. Refer to the log files for more information.

Have checked all the permissions and not sure what logs to check
0
Comment
Question by:cam-e
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
6 Comments
 
LVL 14

Expert Comment

by:Shabarinath Ramadasan
ID: 33457349
Create a new BB account, Wipe the device and try to activate the new account in this device. If that works, then wipe the device again, try to activate the actual user.

Make sure that you do the following tips.
Delete the existing Blackberry account.
Recreate after 10 mins
Then search for this user in the BAS web console.
Click on component information
Edit user
Turn on static mailbox agent = Yes
Make a not of the agent ID.

Try activation
See if the activation mail reaches his inbox.
In the mean time, go to the BB log file and search for MGAT log file for the thread 200 (usually, static agents start with 200)
check if any error comes in.
if so post it.

Good luck
Shaba
0
 

Author Comment

by:cam-e
ID: 33457648

Will try that now with a new device.


I did notice these errors in the MAGT logs before:

[20400] (08/18 02:20:00.576):{0x1DC4} {cameron@myemail.com} MAPIMailbox::MAPIMailbox - OpenMsgStore (0x8004011d) failed, MailboxDN=/o=First Organization/ou=first administrative group/cn=Recipients/cn=cameron, ServerDN=/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=TCS-HK-NODE1/cn=Microsoft Private MDB
[40720] (08/18 02:20:00.592):{0x1DC4} MAPI call failed. Error 'The information store could not be opened.', LowLevelError 0, Component 'MAPI 1.0', Context 649
[20154] (08/18 02:20:00.592):{0x1DC4} User Cameron E not started

I verified the permissions and Besadmin user has both send as and receive as on the accounts.
0
 

Author Comment

by:cam-e
ID: 33458099
I followed the steps and tried activating by the BAS with USB cable.

When i went to assign the device, i got the error:

"The BlackBerry Administration Service was unable to retrieve specific device attributes from the device that is connected to your computer."

The MAGT log still shows:

[
30041] (08/18 02:38:01.218):{0x1120} Starting handheld for Priscilla
[40704] (08/18 02:38:01.218):{0x1120} MAPIMailbox::MAPIMailbox ServerDN=/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=TCS-HK-NODE1/cn=Microsoft Private MDB, MailboxDN=/o=First Organization/ou=first administrative group/cn=Recipients/cn=priscilla
[20400] (08/18 02:38:01.234):{0x1120} {priscilla@ourdomain.com} MAPIMailbox::MAPIMailbox - OpenMsgStore (0x8004011d) failed, MailboxDN=/o=First Organization/ou=first administrative group/cn=Recipients/cn=priscilla, ServerDN=/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=TCS-HK-NODE1/cn=Microsoft Private MDB
[40720] (08/18 02:38:01.234):{0x1120} MAPI call failed. Error 'The information store could not be opened.', LowLevelError 0, Component 'MAPI 1.0', Context 649
[20154] (08/18 02:38:01.234):{0x1120} User Priscilla not started
[50079] (08/18 02:38:01.234):{0x1120} 6 user(s) failed to initialize

Open in new window

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Expert Comment

by:qburt1019
ID: 33458515
It looks like your BESAdmin account doesnt have the full access it needs to your information store.  I had the same issue with MAPI failures because my account didnt have Administer Information Store rights, as well as send as and receive as.
0
 

Author Comment

by:cam-e
ID: 33458889
Have double checked the permissions as per this article: http://www.blackberry.com/btsc/viewContent.do?externalId=KB02276 4 where EMS tells me they already exist.

There is another 20 handsets working fine and i activated one OTA last week.
0
 

Accepted Solution

by:
cam-e earned 0 total points
ID: 33459544
I followed the steps here:

http://www.blackberryforums.com.au/forums/microsoft-exchange/8577-resolved-openmsgstore-failed-8004011d-exchange-2010-a.html

And ran this command:

Add-ADPermission -InheritedObjectType User -InheritanceType Descendents -ExtendedRights
Send-As -User "BesAdmin" -Identity "CN=Users,DC=domain,DC=com

Which seems to have sorted it out. I think i may of had some public folders which just finished replicating from 2003 box and therefore didnt not have a sendas permission. Not sure if that could cause it though.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A little while ago I had a need to reinstall a Blackberry Enterprise server in order to fix a particular problem.  As I did not know the existing certificate password I entered a new one which resulted in the Administration page displaying that it "…
After going through the deployment of BlackBerry Device Service 10, and seeing a number of questions posted about it, this article addresses some of the issues and particulars of the installation. There have been a number of other questions posted, …
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question