Microsoft Smart Card Provider asking for PIN several times when sending signed email

I have a user using a CAC card with Windows 7. We are using the built in smart card provider vs ActiveClient and this has been working well for some time now.

Recently though when the user tries to send signed mail from Outlook 2007, he is prompted at least three times for his PIN by the Microsoft Smart Card Provider before finally working. We are sure the PIN number is correct, but its become quite a nuisance to have to enter the PIN so many times.

Can anyone offer any advice in troubleshooting this?

Who is Participating?
peakpeakConnect With a Mentor Commented:
First try this: Close Outlook, click Start->Run, type Outlook /cleanprofile
If that doesn't do the trick then recreate the Outlook profile. Profile corruption is the source of many strange behaviours in Outlook.
You may first want to save away the address cache (the .nk2 file) which contains the addresses the user has prevoiusly sent successfully. You find the .nk2 file here (XP):
C:\Documents and Settings\<user>\Application Data\Microsoft\Outlook
(Vista / W7: C:\Users\{username}\AppData\Roaming\Microsoft\Outlook)
If you do not know how to recreate a profile:
After recreating the profile you can restore the .nk2 file to the same location assuming you used the same name for the new Outlook profile.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.