Solved

UPS not working in Drupal's Ubercart

Posted on 2010-08-17
3
1,257 Views
Last Modified: 2013-12-13
Please Help.

I have a Drupal 6 site and I've use Ubercart 2 for the store but I can't get the UPS shipping quote to work.

Also is it necessary to have the weight and dimensions set on products?

I get this error message when there is no weight set:

"There were problems getting a shipping quote. Please verify the delivery and product information and try again. If this does not resolve the issue, please call in to complete your order."

And I get the error message below when I add weight and dimensions.

Thank you for your help.
undefined:
Hard 111100: The requested service is invalid from the selected origin.

<?xml version="1.0" encoding="UTF-8"?>
<AccessRequest xml:lang="en-US">
  <AccessLicenseNumber>removed for this post</AccessLicenseNumber>
  <UserId>removed for this post </UserId>
  <Password>removed for this post</Password>
</AccessRequest>

<?xml version="1.0" encoding="UTF-8"?>
<RatingServiceSelectionRequest xml:lang="en-US">
  <Request>
    <TransactionReference>
      <CustomerContext>Complex Rate Request</CustomerContext>
      <XpciVersion>1.0001</XpciVersion>
    </TransactionReference>
    <RequestAction>Rate</RequestAction>
    <RequestOption>rate</RequestOption>
  </Request>
  <PickupType>
    <Code>03</Code>
  </PickupType>
  <CustomerClassification>
    <Code>04</Code>
  </CustomerClassification>
  <Shipment>
    <Shipper>
      <ShipperNumber> A9202x </ShipperNumber>
      <Address>
        <City></City>
        <StateProvinceCode>GA</StateProvinceCode>
        <PostalCode></PostalCode>
        <CountryCode>US</CountryCode>
      </Address>
    </Shipper>
    <ShipTo>
      <Address>
        <StateProvinceCode>GA</StateProvinceCode>
        <PostalCode>30605</PostalCode>
        <CountryCode>US</CountryCode>
      </Address>
    </ShipTo>
    <ShipFrom>
      <Address>
        <StateProvinceCode>GA</StateProvinceCode>
        <PostalCode>30076</PostalCode>
        <CountryCode>US</CountryCode>
      </Address>
    </ShipFrom>
    <ShipmentWeight>
      <UnitOfMeasurement>
        <Code>LBS</Code>
        <Description>Pounds</Description>
      </UnitOfMeasurement>
      <Weight>1.0</Weight>
    </ShipmentWeight>
    <Service>
      <Code>11</Code>
      <Description>UPS Standard</Description>
    </Service>
    <Package><PackagingType><Code>01</Code></PackagingType><PackageWeight><UnitOfMeasurement><Code>LBS</Code><Description>Pounds</Description></UnitOfMeasurement><Weight>1.0</Weight></PackageWeight></Package></Shipment>
</RatingServiceSelectionRequest> 

 <?xml version="1.0"?>
<RatingServiceSelectionResponse><Response><TransactionReference><CustomerContext>Complex Rate Request</CustomerContext><XpciVersion>1.0001</XpciVersion></TransactionReference><ResponseStatusCode>0</ResponseStatusCode><ResponseStatusDescription>Failure</ResponseStatusDescription><Error><ErrorSeverity>Hard</ErrorSeverity><ErrorCode>111100</ErrorCode><ErrorDescription>The requested service is invalid from the selected origin.</ErrorDescription></Error></Response></RatingServiceSelectionResponse>

There were problems getting a shipping quote. Please verify the delivery and product information and try again. If this does not resolve the issue, please call in to complete your order.

Open in new window

0
Comment
Question by:lallen30
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 12

Accepted Solution

by:
junipllc earned 500 total points
ID: 33488841
I have limited experience with the UPS module for Uber, but from looking at the XML above I'd guess that you don't have a City set for the shipper origination. I believe that UPS requires a full address for both shipper and receiver in order to find the appropriate price.

That would be where I would start. I know when I ship anything UPS it requires dimensions, weight, and shipper/receiver addresses using their interface, and I think it would translate roughly to Uber as well.

Definitely something that should be solved and posted here, as I'm sure others will, or have, run into the same problem. Let us know if when you tweak the settings if it starts working.

I'll do a little documentation perusal to see if I can find the exact cause in the meantime.

Good luck!

Mike
0
 
LVL 12

Assisted Solution

by:junipllc
junipllc earned 500 total points
ID: 33488859
Take a look here, at post #3 regarding the three addresses that UPS requires. It's a post from 2008, but it probably applies to your situation as well:

http://www.ubercart.org/forum/module_support/7038/ups_module_default_shipping_address

I'll keep looking.

Mike
0
 
LVL 1

Author Closing Comment

by:lallen30
ID: 33605424
thank you
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article discusses four methods for overlaying images in a container on a web page
3 proven steps to speed up Magento powered sites. The article focus is on optimizing time to first byte (TTFB), full page caching and configuring server for optimal performance.
The viewer will learn how to create and use a small PHP class to apply a watermark to an image. This video shows the viewer the setup for the PHP watermark as well as important coding language. Continue to Part 2 to learn the core code used in creat…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question