Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 526
  • Last Modified:

How can I route mail for one specific domain through another smtp virtual server on port 587 exchange 2k3

I need to route mail to a universal distribution group. I have created the group and entered contacts to it. It is working fine exept for one specific domain, and only when a user from that specific domain tries to send a mail to the distribution group. I get an error on the sender address as non existent, but only for the users on that particular mail domain. 4 users contact information points to a mailbox in the problematic domain, and those four addressees generates the error. But I can without problems do a "send again" to the four adressees (in outlook from my administrator account) and wupti - the delivery is ok. I have access to the mail domain as secure smtp user and I am able to send mail to the domain including if I send mail to the distribution group from my account on the problematic mail domain, but all mail from my domain will go through that particular virtual smtp server - and is therefor relayed through the problematic mail domain server. I do not want all my mail to pass through that mail server. My default smtp virtual server sends and listens on port 25 Only. So here is what I want:

Mail for problematicdomain.com to be sent through specific smtp virtual server comunicating on port 587. The extra smtp virtual server should only handle outgoing mail from my serrver to the problematic domain, including outgoing mail to the distribution group. All incomming mail should be handled by the default smtp virtual server only.

All outgoing mail for any other domain should be sent through the default smtp virtual server on port 25.

Any ideas?
0
xhal99104
Asked:
xhal99104
  • 3
  • 2
1 Solution
 
bevhostCommented:
Well considering how easy this is in linux I though this should be a piece of cake, however it appear that it is not.

I had a quick look for options on an SBS server I look after and it appears to me that you would need to create a virtual SMTP server AND and an SMTP connector.
In the SMTP connector, specify your new Virtual server under Local Bridgeheads as well as problemdomain.com under the address space.  This should make all outbound mail go out via your new Virtual server.

Then configure the virtual server (outbound connections button, delivery tab) TCP Port to 587.  You might need to change the smart host, but DNS lookup will probably work.
I think you might also need to change the TCP port number it listens on so it doesn't conflict with your normal SMTP virtual server (Advanced button) next to IP address Dropdown general Tab.

I haven't tried this of course, but you did ask for ideas!!!

0
 
xhal99104Author Commented:
Than you for your reply. I have tried excactly what you suggested my self, but nevertheless it uses the default smtp virtual server anyway. My next step was to add an IP address to the network chart and use that as listen address on port 25 in order to avoid conflicts as you mentioned. I have also tried to change the listening port to another one, but then all trafic goes through the default smtp virtual server. I have now succeded in routing through the second virtual server using somewhat your procedure, but something goes wrong in the connection. The remote server does not answer the connector yet. I will try to call the administrator of the problematic domain in order to figure out what to do. But the strange thing is, that if I route all trafic through the secondary smtp virtual server it seems to work?? As soon as i try to route through a smtp connector something happens and the communication is terminatede some how .The messages queues up in the unreacable queue. It is actually very strange.
0
 
bevhostCommented:
Download a copy of putty.exe and change the connection to Telnet Port 587 enter the destination hostname and see if you can connect.

http://www.google.com/search?q=putty+download
0
 
xhal99104Author Commented:
There is connection, and it is actually working now. I started all over again, got the secondary smtp server up working with all mail. Then I gave it a new IP to listen on but still on port 25. I guess that was one of the problems. It must listen on port 25 in order to function with the routing connector. Secondly I found out, that the routing connector must have relay permission, and that the scope must be set to "routing group" not "entire organisation". on the address space page.
0
 
xhal99104Author Commented:
it was not possible to make it work as described in the solution by changing the listening port on the secondary smtp virtual server. I needed to add an extra IP address to the network chart and still listen on port 25. Otherwise the solution was ok.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now