Solved

Fastream Secure FTP Setup

Posted on 2010-08-17
5
631 Views
Last Modified: 2013-12-02
I've had Fastreams FTP server running for years on a server behind a firewall.  I now need to setup a secure FTP host as well.  The port 990 is open.  I created a new ftp to listen to port 990 in the program.  I am able to connect to the new FTP server and authenticate with FileZilla from a remote location.  The problem begins when I try to get a directory listing.  In the FTPS I see:

Response:      227 Entering Passive Mode (10,192,1,23,39,16). --10.192.1.23 being the internal IP address of the server.
Status:      Server sent passive reply with unroutable address. Using server address instead.
Command:      LIST
Response:      150 Opening data connection for folder list.
Error:      Connection timed out
Error:      Failed to retrieve directory listing


When I log into the working FTP I see something like this:

Response:      227 Entering Passive Mode (xx,xx,xx,xx,12,104).-- Where xx.xx.xx.xx is the external IP address
Command:      LIST
Response:      150 Opening data connection for folder list.
Response:      226 File sent ok
Status:      Directory listing successful

Any suggestions?  I am aware the Fastream only supports explicit and I have that selected in FileZilla.

On the firewall log it shows:  the port 990 is connecting fine but then it fails trying to go to port 10000

any ideas?
0
Comment
Question by:ekee
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 

Author Comment

by:ekee
ID: 33488219
It seems like the failure is in the way my network is set up?  Maybe the NAT?
0
 
LVL 32

Expert Comment

by:dpk_wal
ID: 33488531
If the client uses active mode instead of passive is the problem eliminated; if yes, then we need to set up NAT differently on WG.

Thank you.
0
 

Accepted Solution

by:
ekee earned 0 total points
ID: 33628995
I eventually worked it out myself.  The solution required all of the following - Manual Passive Mode, turned on.  WAN IP selected and entered.  Passive port range set and we had to open the same ports on the WG.  It's a little clunky but it works.
0
 
LVL 32

Expert Comment

by:dpk_wal
ID: 33629033
Thank you for the update.
0

Featured Post

Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Understanding FTPS File transfer is a common requirement in most Enterprises. While there are numerous ways to get a file from Point A to Point B over a network, perhaps the most common method still in use is FTP – File Transfer Protocol. FTP is …
Preface There are many applications where some computing systems need have their system clocks running synchronized within a small margin and eventually need to be in sync with the global time. There are different solutions for this, i.e. the W3…
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question