Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

SBS 2008 cannot change to "optimize for quick removal"

Posted on 2010-08-17
10
Medium Priority
?
1,643 Views
Last Modified: 2012-05-10
I have a SBS2008 server that I am trying to back up on external USB drives. Hardware is a Dell R200 rack server. When I go to properties of the EHD and go to properties-policies, the "Write caching and Safe Removal" is set to "optimize for performance" and the settings are greyed so I can't change it to "Optimize for Quick Removal".  How do I change the setting?
Thanks
0
Comment
Question by:KentMiller
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
10 Comments
 
LVL 5

Assisted Solution

by:TechnicallyMaybe
TechnicallyMaybe earned 2000 total points
ID: 33458538
Uncheck Enable Write Caching and apply.  You should have the option to optimize for quick removal.
0
 

Author Comment

by:KentMiller
ID: 33459844
I did some more checking and if I go into "change settings" on the device settings page, I have the option to  select "Optimize for Quick Removal". I select it and go back to view settings and " optimize for Performance " is still showing as the selected option. I have even rebooted the server after selecting " Optimize for Quick Removal " and it still will not change.
0
 
LVL 5

Expert Comment

by:TechnicallyMaybe
ID: 33460576
This reg change will force the drive to use optimize for quick removal:
   1. Click Start, click Run, type regedit in the Open box, and then click OK.
   2. Locate and then click the following subkey in the registry:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\<XXX>\<YYY>\<ZZZ>\Device Parameters\Classpnp
      Note In this registry subkey, XXX, YYY, and ZZZ are the strings that represent the disk device that you are using.

      For example, a sample SCSI MO device might have a Classpnp subkey that is similar to the following:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SCSI\Optical&Ven_XXXXX&Prod_YYYYY&Rev_0800\4&1faa839c&0&050\Device Parameters\Classpnp


      Note if the Classpnp subkey does not exist, you must create it. To do this, click Edit, point to New, and then click Key. Type Classpnp for the name of the subkey, and then press ENTER.
   3. With the Classpnp subkey selected, click Edit, point to New, and then click DWORD Value.
   4. Type UserRemovalPolicy for the DWORD name, and then press ENTER.
   5. Right-click UserRemovalPolicy, and then click Modify.
   6. In the Value data box, type 3, and then click OK.
   7. Exit Registry Editor.
   8. Restart the computer.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:KentMiller
ID: 33461707
I checked the registry and all of the settings you called out were there for the Seagate Free Agent Go Drive (500GB) I went into Device Manager and looked at the drive in the Disk Drives section. In Device Manager, if you look at Device Properties-Policies, it shows "optimize for quick Removal". But if I look in Computer - Disk Drive -properties - hardware - All disk drives - Seagate Free Agent Go - policies - it is selected "Optimize for performance" . I cannot use "Safely Remove Hardware" as it gives me the message Problem ejecting USB device -can't stop generic volume because it is in use. I have checked and the drive is not set up for shadow copy and is not shared.
0
 
LVL 5

Expert Comment

by:TechnicallyMaybe
ID: 33461841
Make sure Windows is not indexing that drive.
0
 

Author Comment

by:KentMiller
ID: 33467269
I had already shut off indexing.
0
 
LVL 5

Expert Comment

by:TechnicallyMaybe
ID: 33467601
Is real-time antivirus running? Stop in and then try to remove.
0
 

Accepted Solution

by:
KentMiller earned 0 total points
ID: 33472305
I found the problem and the solution. When  setting up, Roles, File Srvices, Windows Server 2003 Indexing Services was installed. I uninstalled it and installed Windows Search instead and now I can eject the drive. Thanks for the other areas to check.

Kent
0
 

Author Comment

by:KentMiller
ID: 33553998
EE will not let me close this question. I award all the points and it says I must award at least 20 pts. EE is working on the problem.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The SBS 2011 release date (RTM) is supposed to be around Christmas, 2011.  This article is a compilation of my notes -- things I have learned first hand.  The items are in a rather random order, but I think this list covers most of what is new and d…
The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question